ztc doesn't start from command line but the Studio runs normally


I am using Zerynth Studio for some time without any problem. Today I tried to start ztc from command line but it didn’t start; just an output like: C:\Users\Murat Tolo
It is strange because the full path to zerynth2 directory is C:\Users\Murat Toloğlu\zerynth2 ,  It looks like the smooth g (ğ) in my surname cuase a conflict. I didin’t try to change my username in win7 because it is not easy and may cuase other problems.
Could anyone help me to resolve this issue. 


Further to my above problem; if I click “create repository” on Zerynth Studio menu I get: 

[info] Committing changes to local repository…
[info] Ok
[info] Pushing changes to remote repository…
[error] unpacking the sent packfile failed on the remote

and if I re-load the project I get:
Checking for updates…
[warning] No branch master in remote zerynth

perhaps the two problems are related!?


On this occasion I will also appreciate to learn how to manually configure the project local repository to use my own Github account instead of Zerynth backend, and how to manually perform unsupported git commands like “merge” from command line. Thanks a lot.


Hi ta1db,

yes, regarding the ztc commands, this is a very weird behavior, even because Zerynth Studio uses, in many of its functionalities, the ztc commands in background.
Did you open the prompt with particular authorizations (admin)?

Processing special chars and spaces in the username for Windows machine caused a bad functioning of the ztc in a very old version of the Zerynth Studio (r2.0.4 if I remember correctly) and this has been fixed in all subsequent releases.

Furthermore, in those cases, even the Zerynth Studio, for those features that needed a ztc command execution (for example the registration of a new device or the recovery of the profile information, did not work properly.

Ztc commands can also be launched from wherever (not necessarily from the folder where the * .exe file is saved) and when you run “ztc”, you should get the help section - like this:

``Usage: ztc.py [OPTIONS] COMMAND [ARGS]…

Zerynth Toolchain.

-v Verbose.
–colors / --no-colors To enable/disable colors.
–traceback / --no-traceback To enable/disable exception traceback printing
on criticals.
–user_agent TEXT To insert custom user agent.
–pretty To display pretty json output.
-J To display the output in json format.
–help Show this message and exit.

aws ztc and AWS cli integration
clean Clean up old installations and temp files
compile Compile a project.
device Manage devices.
info Display info about ZTC status.
link Generate bytecode runnable on a specific VM.
linter Python linter.
login Obtain an authentication token
ota Manage OTA updates
package Manage packages.
profile Manage account info.
project Manage projects.
register Obtain an authentication token
reset Password reset.
thing Manage connected devices
uplink Uplink bytecode to a device.
vm Manage Zerynth Virtual Machine.

<div>Please try to open a prompt with accessing with your normal user (the same you uses to run Zerynth Studio) and let me know.<br><br>Regarding the "create repository" issue, this is a known bug (completely unrelated to the first problem) and we're already working on it; stay tuned for new updates.<br><br>The usage of Github&nbsp;in parallel with the Zerynth&nbsp;git is possible and 100% compatible; if you have your project in a Github&nbsp;repository the "create repository" command from the Zerynth Studio will add a remote called zerynth&nbsp;(with its related url) in the ".git/config" file,<br>In this way, you can use the standard command line syntax of git for both Zerynth and Github repo, and if you want to interact with the Zerynth&nbsp;repository, you have to tap zerynth&nbsp;instead of origin for remote commands; here an example for push operation:<br><br><pre class="CodeBlock">`git push origin master --> if you want to push in your Github repository

git push zerynth master --> if you want to push in your Zerynth repository`

Hope this can help you; keep me posted :wink:


thank you very much @“Matteo Cipriani”, I will study your reccomendations very carefully.