Ztc command gives error on Windows 10


#1

I am using Zerynth Studio version : r2.1.1-base on Windows 10.

I intend to use the ztc aws add-thing … command inorder to generate the certificate and provision the device for AWS IoT. So, that’s when I became aware of this error.

For the ztc command on the Command Prompt on Windows 10, I am getting the following error :

**

C:\Users\Vineet Sharma\zerynth2\sys\python\python.exe: can’t open file ‘C:\Users\Vineet’: [Errno 2] No such file or directory

**
Please check the print screen -

I have tried to run the command prompt as Administrator, added the above path (i.e. C:\Users\Vineet Sharma\zerynth2\sys\python\ ) in the system environment variable - but still this problem is persisting.

I am able to use the Zerynth Studio, am able to create virtual machine, was able to do the registered for the Zerynth Studio etc.

Please guide me as to how should i solve this issue.

Thanks.


#2

Hi @geekyvineet,

thank you for reporting this issue which is caused by the presence of a space in your username, we will fix it as soon as possilbe.

In the meantime, to use the ztc from the command prompt you should be able to execute the ztc Python script:
"C:\Users\Vineet Sharma\zerynth2\sys\python\python.exe" "C:\Users\Vineet Sharma\zerynth2\dist\r2.1.1\ztc\ztc.py"

Let me know :slight_smile:


#3

Hello LorenzoR:

Thanks for the response.

I tried the command prompt which you have suggested and it worked ! :grinning:

Thanks you so much !

Best Regards,

Vineet Sharma