Zerynth Studio Issues with every OS


#1

I’m having trouble setting up Zerynth Studio on my machine. I’m running Windows and Linux Ubuntu on Parallels VM on Mac, and both VMs seem to be having issues.

On my Windows VM, Zerynth Studio seems to have installed correctly but when I select the version and press “Start” on Zerynth Studio Launcher, the window goes away and reappears with the exact same window of making me press Start. Even when I don’t press any buttons, the window continues to disappear and reappear. I have tried uninstalling, restarting the OS, reinstalling, but it seems to remember which versions I installed every time.

On my Ubuntu, I had to disambiguate the device on Zerynth Studio, but it fails to install dependencies. Particularly, it fails after downloading package vhal.zerynth.armcmx_stm32f7. I’m using ST Nucleo F429ZI for my board.

I’ve also tried using my Mac also, but when I try to register my board, I get an error message saying “Can’t retrieve chip id”.

I’ve tried everything on the forum boards and other suggestions, but with no success.


#2

Hi @scottpark, it’s hard for me to find out the exact problem from your message, but I can suggest something you can try:

  • Virtual Machines can be tricky because of USB serial ports not being passed through from the host system, I’d suggest to avoid using them as many different problems may arise
  • If I understand correctly, you are using Mac OS, in this case no external drivers are needed for the F429ZI, are you sure that you are using the right USB port of the board? Check this image https://docs.zerynth.com/latest/_images/st_nucleof429zi_pin_io.png and plug your board to the “USB Programming Port”.

If you still can’t virtualize the board I’ll have a deeper look into it.

Thanks,
Antonio


#3

It seemed that something was wrong with the computer I was using. On a different computer, everything seems to work fine!


#4

Well, glad to hear that! Have fun with Zerynth :smile: