Zerynth show the "nw.js"


Morning Everyone,

I’ve installed zerynth so I can take advantage of connecting my micro controllers to aws. My session was find the first time I opened it, but after I started up my computer today it shows this window :frowning:

Any suggestions to have a consistent zerynth session without having to see this window


Since Zerynth IDE worked fine the first time, This means it has all the dependencies needed to open the application.
Did you install any package or install any update after you closed the application?


If you pin Zerynth app in your task bar, it will not work. Try run the app from the start menue


I’m going to try that method out now


That was it! its working like a charm now @abufaisal2


Thanks @pres-iot-developer you for reporting this and thanks @abufaisal2 for the solution, we will try to fix it ASAP.


Hi all,

the problem is that you pin the wrong application…Zerynth is composed by 2 applications: the installer and the Zerynth Studio.

The installer is the Zerynth.exe file in the path “C:\Program Files\Zerynth”.
Zerynth Studio is the main application under the path “C:\Users\your_user\zerynth2”.

To start correctly Zerynth Studio, you need to run always the Zerynth installer (Zerynth.exe) because the installer asks you which version you want to start, and performs in background other checks regarding updates and patches.

So if you want to pin in your taskbar the Zerynth Studio and start quickly the application, you have to go inside the folder “C:\Program Files\Zerynth” and right click over Zerynth.exe file; then you have to click the “pin to taskbar” option.

Zerynth icon will appear on your taskbar and from then on you can start from there the Zerynth Studio application.

Hope that this can help you :slight_smile:


@Matteo_Cipriani, I’m going to try it out and restart my computer.


@Matteo_Cipriani, great catch, seems to be working properly now. Normally when I launch an application, I pin it to the taskbar during my session as a habit.