Zerynth recognized the wrong board SAMC21 instead of SAML21


I have a Atmel SAML21 Xplained Pro board, but when plugged into the computer, Zerynth recognized the device as Xplained Pro SAM C21 instead of Xplained Pro SAM L21.

How can I resolve this?

Thank you,

Just an update, I’ve tried another SAML21 Xplained Pro board and the same thing happened, Zerynth recognized the board as Xplained Pro SAM C21. I was hoping for my team at the company to try out Zerynth, but I guess it is too early? Too much bugs? I guess we are going to stick to Atmel ASF for now.

Hi @hunghp
We are sorry that you are experiencing this bug, Please let us have a look at this issue and I’ll let you know the updates ASAP.

@karimhamdy1, thank you and we’ll wait for your update.

Hi @hunghp
Some boards like the ATMEL Sam cannot be automatically recognized by Zerynth Studio and need a disambiguation
Could you try to “forget” the device then disambiguate the device?

With the device connected to your machine, you have to click the ‘Info’ button on the top bar and click “Forget”; the device manager toolbar will blink yellow and then after few seconds Zerynth Studio will ask you to disambiguate the device and you can select the SAML21 Xplained instead of the Xplained Pro SAM C21. and try again the registration phase.

Thank you so much,

I’ve tried with two SAM L21 board, so when I forget and disambiguate device, I have the following options, but none is the SAM L21 board. I don’t think it is Atmel fault, could it? Because Atmel Studio recognized the board correctly. Please see the caption below

This is quiet strange, Could you tell me which Zerynth version are you using and which OS are you running?

So we are using.

  1. Zerynth version 2.3.3-base
  2. Windows 10 Pro