Zerynth not shutting down properly?

In an earlier post I talked about trying to modify the colour themes used by Zerynth Studio. As I was experimenting with changing things I had to shut down and restart Zerynth every few minutes. The first thin I noticed was that Zerynth was not deleting its singleton lock ~/.config/Zerynth/SingletonLock so I had to go in and manually delete it every time I wanted to restart Zerynth. After an hour or two my PC suddenly slowed down dramatically and I couldn’t start programs. I managed to get the system monitor up and saw that there were literally hundreds of Zerynth processes active. I killed them all and restarted Zerynth again, and had a look at the monitor. There were six Zerynth processes active, as per the screenshot.

image

So I shut down Zerynth again, and checked the monitor again.

image

There are still three Zerynth processes active, and they never go away. I’m guessing that may be why Zerynth is not deleting its lock file.

image

I started zerynth using the command line as I haven’t set up a menu item for the new version yet, and also to show the messages related to it. You can see that is has not terminated because the command prompt has not reappeared. And never does until I kill the three zerynth processes running.

I am closing Zerynth by hitting the “X” close button on the top right corner. I’ve tried using the Preferences->Quit option too, but the result is the same.

Have I got the setup wrong somehow? I downloaded the latest version (2.4.1) and extracted it into my Downloads folder, then ran it from there using the command line. I have version 2.4.0 installed in my /opt folder (/opt/zerynth-2.4.0) and set up a start menu item to start it (using the Cinnamon menu editor). Dunno if that had any significance though… Is there anything else I need to do or anything I can check?

:-\

hi @mogplus8
Unfortunately, I couldn’t reproduce your problem on my machine, I am using the Latest Ubuntu distro.
I am running v 2.4.1 the processes are terminated normally when I exit Zerynth Studio.
I also tested this on Windows.
Which Linux distro are you currently using?

Hi @karimhamdy1, thanks for the quick reply.
I’m using Linux Mint 19.3, built on top of Ubuntu. I installed 2.4.1 thinking maybe there was a problem with 2.4.0 but the behaviour persists. I’ve noticed it occurring in previous versions too, but it was intermittent. Now it’s every time. That’s why I was thinking it must be something to do with my setup, as nobody else seems to be having the problem. I’ve got no idea what I might have done. I’ve been using Mint for quite a while now, so maybe some libraries have been screwed somehow or something. I was hoping you might be able to say “just reinstall xyzlib and it will all work”.
Maybe it’s time for a reinstall… I’ve done it before when Mint seemed to get a bit old and crusty.
:wink: Ian

*** EDIT ***
Tried installing it on Manjaro (Arch based). Install fails as library gconf-2.so.4 missing. A bit of googling told me I need to manually install gconf, which I did and Zerynth installed. It runs fine and a) does not create six zerynth processes, only three, and 2) shuts down properly and deletes its lockfile. So it looks like an issue with my Mint install. But where to start… :frowning:
My problem with the vanishing find/change dialog persists though. Even more puzzling as this was an absolutely clean install of Zerynth. Sometimes ctrl-F works, sometimes it doesn’t. If it doesn’t work, restarting Zerynth usually fixes it. I thought the problem (in my Mint install) was created by me mucking around with the theme files, but I haven’t touched anything here.

1 Like

Hi @karimhamdy1, it gets weirder. I noticed that when I start Zerynth, three processes are started by the startup dialog (that asks what version you’d like to start) just before that there’s a dialog that says my preferences can’t be read (but they are). Normally this dialog is hidden behind the startup dialog and disappears when Zerynth starts. I stopped the automatic start by selecting the dropdown, so I was able to get the screenshot. Then, just for fun, I clicked OK on the “can’t save your preferences” dialog, and then clicked start on the startup dialog. Imagine my surprise when Zerynth started properly! Only three processes shown in the monitor! And it shut down correctly too, and deleted it’s lock file. So it looks like the problem may lie with the first error dialog. Not sure how or why, but maybe it might give your gurus a clue. Maybe I just need to adjust something so that dialog doesn’t come up and all will be well.
Thanks, Ian

Hi @mogplus8
Thanks for that detailed information, As you said I think all of these issues are from your setup settings, Mainly the linux distro and the dependencies used by Zerynth.
We will have a look at your post and replies and If we have any ideas we will keep you updated.
Thanks.

Thanks @karimhamdy1, at least I have a workaround for now. I just have to click the dropdown, click OK on the dialog, and then click Start and I’m away laughing.

:wink: Ian