Zerynth(Linux version)Installation on Raspberry Pi

I’m trying to install Zerynth IDE(Linux) on my RPI4. I have already copied the unzipped zerynth.tar.xz on the RPI. And I typed the following command using terminal.

pi@raspberrypi:~/Downloads/zerynth $ ./zerynth

But I got the following error.

“Permission denied.”

I REALLY want to install Zerynth IDE or Zerynth CLI environment on my RPI4.
Is it possible? Please let me know how should I do this.

Thanks in advance.



We have never tried Zerynth Studio on the RPI, but the problem you are having is not connected to the platform itself!

Have you tried changing the permission of the executable with chmod?


Thanks for your reply.
I have already tried to change the permission using chmod command.

Then I see “cann’t execute binary file: Exec format error”

How can I do to solve this problem.
I’ll be very happy when I got any solution from you soon.


Hi @Anatoli_Juny
Unfortunately, Zerynth studio is compiled for x86-64 Architecture, it hasn’t been ported/compiled for ARM architecture.
Since the raspberry pi is an ARM architecture based SOC, It can not execute/open Zerynth.