Zerynth ide doesn't install on fedora 28 with lxqt


#1

Hi, when i try to install the ide on my fedora 28 with lxqt I receive the error and nothing else happens:

# ./zenyrth
/opt/zerynth/node_modules/mkdirp/index.js:90
                    throw err0;
                    ^


    Error: EACCES: permission denied, mkdir '/root/.zerynth2'
    at Object.fs.mkdirSync (fs.js:846:18)
    at sync (/opt/zerynth/node_modules/mkdirp/index.js:71:13)
    at Function.sync (/opt/zerynth/node_modules/mkdirp/index.js:77:24)
chrome-extension://plgpmongdcepdpdjaljokkmjdbfghjea/js/base.js:162
    var mjfile = path.join(env.tmp,"major_release.json")
                              ^

TypeError: Cannot read property 'tmp' of undefined
    at startup (chrome-extension://plgpmongdcepdpdjaljokkmjdbfghjea/js/base.js:162:31)
    at HTMLDocument.<anonymous> (chrome-extension://plgpmongdcepdpdjaljokkmjdbfghjea/index.html:177:22)
    at j (chrome-extension://plgpmongdcepdpdjaljokkmjdbfghjea/bower_components/jquery/dist/jquery.min.js:2:26925)
    at Object.fireWith [as resolveWith] (chrome-extension://plgpmongdcepdpdjaljokkmjdbfghjea/bower_components/jquery/dist/jquery.min.js:2:27738)
    at Function.ready (chrome-extension://plgpmongdcepdpdjaljokkmjdbfghjea/bower_components/jquery/dist/jquery.min.js:2:29532)
    at HTMLDocument.I (chrome-extension://plgpmongdcepdpdjaljokkmjdbfghjea/bower_components/jquery/dist/jquery.min.js:2:29723)

Thanks for help.