Zerynth doesn' t recognize MKR1000


#1

(Win10 & Linux)
MKR1000 drivers are installed correctly and I tried to connect the Arduino by USB with different versions of Zerynth in both operative systems. In all cases Zerynth blink an orange box but no decive was found
(Zerynth doesn’ t give me any information or error)

Thanks for your help!


#2

Hi @Lorenzo_Nardi,

this is strange since on GNU/Linux the board should be recognized without user intervention.
Can you tell me the output of the lsusb command when the board is plugged?

Please also attach the output of the ztc device discover command run from the command line.

Then double click the RST button and repeat the procedure.
Thank you


#3

Ooook Solved. Thank you very much! with the command ZTC, said to me COM4 as port, after double click on RST button (I didn’ t do it before) the port change to COM7 and Zerynth saw the Arduino! I have to do this procedure every time but it isn’ t a problem! :+1:


#4

Hi @Lorenzo_Nardi,

from the docs you can see that double clicking the reset button puts the device in virtualization mode, needed to flash the Zerynth Virtual Machine.
After virtualization the device should be ready for uplink without repeating this procedure.

Let me know


#5

Yes, after few tests I saw the device was ready and now I shouldn’ t repeat the procedure.
Because of my low competence, I don’ t understand how to connect MKR with wifi and how to save into flash memory a PY module. Can someone help me?


#6
  1. You could try our HTTP Time example substituting from broadcom.bcm43362 import bcm43362 as wifi_driver line with from microchip.winc1500 import winc1500 as wifi_driver.
    This will automatically set the proper mkr1000 network layer.

  2. Python module are saved on mcu flash memory when included in your project and the project is uplinked

:slight_smile: