Ublox nina b112 (nrf52832) - stlink v2

hi, to remove this error

[info] Starting temporary probe…
[info] Checking probe health…
[info] Starting OpenOCD…
xPack OpenOCD, 64-bit Open On-Chip Debugger 0.10.0+dev (2019-07-17-11:28)
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
Warn : Interface already configured, ignoring
Error: Debug adapter doesn’t support ‘swd’ transport
*C:\Users\Usuario\zerynth2\dist\r2.6.4\sys\openocd\scripts\board\nordic_nrf52_dk.cfg:7: Error: *
*in procedure ‘script’ *
at file “embedded:startup.tcl”, line 26
at file “C:\Users\Usuario\zerynth2\dist\r2.6.4\sys\openocd\scripts\board\nordic_nrf52_dk.cfg”, line 7
[info] Checking probe health…
[info] Checking probe health…
[info] Checking probe health…
[info] Checking probe health…
[warning] Temporary probe may be dead…
[warning] timed out
[warning] timed out
[error] Can’t retrieve chip id

I had to modify nordic_nrf52_dk.cfg to

source [find interface/jlink.cfg]
ransport select hla_swd
source [find target/nrf52.cfg]

and now i got

Starting OpenOCD…
xPack OpenOCD, 64-bit Open On-Chip Debugger 0.10.0+dev (2019-07-17-11:28)
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
Warn : Interface already configured, ignoring
Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD
Info : Listening on port 6666 for tcl connections
Info : Listening on port 4444 for telnet connections
Info : clock speed 1000 kHz
Info : STLINK V2J37S7 (API v2) VID:PID 0483:3748
Info : Target voltage: 3.163708
Info : nrf52.cpu: hardware has 6 breakpoints, 4 watchpoints
Info : Listening on port 3333 for gdb connections
[info] Info : accepting ‘telnet’ connection on tcp/4444Ok
Info : dropped ‘telnet’ connection
[warning] reset halt
Info : accepting ‘telnet’ connection on tcp/4444
[warning] mdw 0x10000060
[warning] mdw 0x10000064
*target halted due to debug-request, current mode: Thread *
xPSR: 0x01000000 pc: 0x000002b8 msp: 0x20010000
[info] Waiting temporary probe…
Info : accepting ‘telnet’ connection on tcp/4444
shutdown command invoked
Info : dropped ‘telnet’ connection
[info] Stopped temporary probe…
[info] Chip id retrieved: 25feab24041xxxxx
[info] Device registered with uid: P_XDPSxxxxx88doQg
Registration successful! Now you can virtualize your nordic_pca10040
[info] Updating device…

But when i try to upload the bin


can you help me ?

hi @Miguel_Wisintainer
Thanks for reporting this, We need to investigate this further, We will test the board with V2.6.4 and will keep you updated.
thanks.