Trouble with ESP32 OTA getting an error on ztc ota prepare command


#1

Device/Program Info
ESP32-WROOM-32 (using the Dev Type VM esp32_devkitc)
Using a VM FreeRTOS FOTA enabled VM (version r19.07.24)
Zerynth Studio Version r2.3.0-base

I’m new to Zerynth and I’m trying to get the example for FOTA updates working, but I’m running into issues.

I’m getting stuck at the ZTC linking and I’m getting the same results on both Windows 10 and Debian. After I compile the .py file into a .vob file and then use the ./ztc link command I am able to get the .vbe file. However, when I try use the command: ./ztc ota prepare esp32_devkitc main.vbe I get an error (I can send the entire error output if needed) but it ends with the following:

UnicodeDecodeError: ‘utf-8’ codec can’t decode byte 0xea in position 6: invalid continuation byte.

I get the same result on both windows and Debian and the same result regardless of what I put in for “Device” in the ./ztc ota prepare command.

I’ve tried using the Zerynth Studio but no luck there either. When I click the “Connected Device” button on the left of the Zerynth Studio GUI all devices say “No bytecode ready” Last FOTA: –. I’m not sure how to get these to do anything. If I click the “Prepare bytecode” button nothing happens. I’ve loaded the Example program onto the ESP32 and the LED blinks and the ESP32 connects to the WIFI.

One other question, how do I remove items from the “connected devices” list? I don’t see any delete or remove option.

Thank you,
David