The inner doc error of NodeMCU_ESP32S


#1

Whe I register the device (NodeMCU_ESP32S)
I got this error

Chip is ESP32D0WDQ6 (revision (unknown 0xa))

Uploading stub…

Running stub…

Stub running…

Changing baud rate to 1500000

Changed.

Traceback (most recent call last):

File “C:\Users\e8505\zerynth2\sys\esptool\esp32\esptool.py”, line 2405, in

_main()

File “C:\Users\e8505\zerynth2\sys\esptool\esp32\esptool.py”, line 2398, in _main

main()

File “C:\Users\e8505\zerynth2\sys\esptool\esp32\esptool.py”, line 2137, in main

esp.change_baud(args.baud)

File “C:\Users\e8505\zerynth2\sys\esptool\esp32\esptool.py”, line 61, in inner

return func(*args, **kwargs)

File “C:\Users\e8505\zerynth2\sys\esptool\esp32\esptool.py”, line 538, in change_baud

self._set_port_baudrate(baud)

File “C:\Users\e8505\zerynth2\sys\esptool\esp32\esptool.py”, line 185, in _set_port_baudrate

self._port.baudrate = baud

File “C:\Users\e8505\zerynth2\sys\python\lib\site-packages\serial\serialutil.py”, line 345, in setBaudrate

if self._isOpen:  self._reconfigurePort()

File “C:\Users\e8505\zerynth2\sys\python\lib\site-packages\serial\serialwin32.py”, line 202, in _reconfigurePort

raise ValueError("Cannot configure port, some setting was wrong. Original message: %r" % ctypes.WinError())

ValueError: Cannot configure port, some setting was wrong. Original message: OSError(22, ‘The parameter is incorrect.’, None, 87)

And I found someone have similar problem,
The solution is to modify the internal files of zerynth
just open the file at

C:\Users<Your_User_Name>\zerynth2\dist\r2.2.0\devices\nodemcu_esp32
and it’s at Ln50 column 110
Change the “–baud","1500000” to "--baud","115200"


#2

Hello @Chang_Chen_Chien,

we are going to fix it with the next update.