Spresense with OSX


#1

Dear ,

I renewed my interest in using Zerynth as I noticed that the Sony CXD5602 is supported now. I installed the latest version on my MacBook (Mojave) and tried to get it running.

Installing Zerynth was not enough. The missing piece is the Syllabs driver for the USB connection.
After installing that missing piece the Sony SPresense became visible and programming the boot loader and virtualising it worked.
Now I tried to upload the gnss example and the three leds blinking, but every time it could not download it. It seems like some timing issue.

After tying a few times I took the step to fire up my Windows PC and do the installation all over again and it worked without a hitch.

Would you please check out the issue with OSX?


#2

Dear @roland_van_straten,

thank you for your renewed interest in Zerynth :slight_smile:

As a hint for the future, drivers needed by a specific board are always reported in our documentation: here, for example, you can find Spresense docs.

Concerning the OSX issue, we successfully tested the board on our Macs, but it looks like you are facing a reset issue: can you check if the board resets when you try to uplink? You can detect the reset clearly since the LED starts blinking.

Let me know


#3

Hello Lorenzo: Regarding the Spresence module. Zerynth must have these on hand to have written drivers for them, and I am curious whether the Spresense GPS feature works properly indoors.It looks like only the on-board antenna is possible.
Recently I had no luck getting a fix on GPS satellites with a common NEO6MV2 GPS module indoors, even near a big window. Does the Spresense work indoors?
Thank you


#4

Hello All,

I tried to same thing, but I can not “burn” and got a Message “Cannot execute selected action on this device”.
I tried MacBook 2017+ USB-C hub first, no luck.
I tried iMacPro 2017, I can not install USB device driver. Security manager did not display the alliance button…
Their versions are 10.13.6.

I also tried on windows 10, but I got same error.
I also tried with Adafruit Feather M0 WiFi, it seems to work with Blink LED but can not connect serial console with above combinations.

Is there any suggestions?

Tosy