[SOLVED] Problem with import adc


#1

I have a problem with use the import adc. When I compile the code, sometimes  return this error " Error in C natives [---] in [/home/virginio/.zerynth2/dist/r2.0.6/vhal/armcmx/stm32f4/vhal_dma.c] at line 0" and other times "Error in C natives [---] in [/home/virginio/.zerynth2/dist/r2.0.6/stlid/csrc/vbl/vbl_adc.c] at line ".

Without the import adc, I haven't the error but, for example, when I use the potentiometer doesn't work because don't read the value (value: none).

I tried it on another computer with the same OS and it works well. What is the problem? I'm not the only one with this problem.

I also tried uninstalling the framework and install it again but I get the same problem.


#2

Hi virginiodv,

Which platform and os version are you using?
If you are using a linux machine maybe you need to install the gcc-multilib package from the terminal.

Let me know if this can help you :slight_smile:


#3

solved with:
sudo apt-get install gcc-multilib


#4

After installing gcc-multilib I resolved the problem but after using the micro controller a few times it gives me an error when I uplink and when I go to virtualize.
It is as if the computer can’t read the micro controller although zerynth reads.

This is the error when I uplink the program: "Device has no serial port! Check that driver are installed correctly"

The error when I virtualize the device is: “Error in virtualization Can’t find device disk! Have you mounted the ST Link device?”







#5

This issue is very weird; have you try to update the ST-Link firmware (link) or change the usb port?

Let me know if this can help you