Sending bytecode / uplinking nRF52 DK doesn't work

Hi, I’ve just connected nRF52, registered device, added virtual machine, virtualized it and trying to test “Hello Zerynth” code. Compilation went fine but the uploading code doesn’t work… uplinking for several minutes and then stoped it (see the attachment). Thx for your help

Hi @fitnet
This might be due to a hardware problem, Have made any hardware changes to any of the soldered pins on the DK?
If not, Could you please try to re-register and re-virtualize again?:smile:

thx for the quick response. No, I didn’t make any changes on the hardware. I’ve got the device yesterday… ran some examples with Segger Embedded Studio successful… and now tried to do the same with Zerynth, with this error above… already tried to re-register, re-virtualisation… no changes

This is quite strange since the device is recognized and virtualized correctly.
Could you try updating the JLink drivers and try again?

didn’t work… I’ve just ordered an additional device

I’ve ordered this time nRF5340 PDK, but you don’t support it? :frowning:

Unfortunately, The nRF5340 is not yet supported, Please have a look at the supported devices list for the full list of supported devices.

now I’ve got a new nRF52 device… started testing again… here is the result

[info] Starting device registration
[info] Burning bootloader…
[info] Burning bin
[error] Can’t find chipid

hi @fitnet
Which OS are you currently using?
Are you able to open the device using a serial monitor?