Problems with RFID module and SD module when used together

Hi, I’m trying to integrate both an SD module and the RC522 RFID module with my esp32 devkitc board. Both use SPI to communicate. I use SPI0 to communicate with the RFID module and SPI1 to communicate to the SD module using zerynth fatfs as written in the examples.
The problem exists if I connect both. If only one is connected, it works perfectly.
How can I solve the problem?

Are you sure there are no runtime errors in both SPI codes? specifically in the RC522 RFID.
Have you tried putting it in a try and catch block?

It is already in a try except block. They work if connected separately. The error Is
“spi_master host already in use”, even if they are connected to different bus.

Hi @ViRiccio
Are you sure you initialize different SPI instances and using different CS pin for each device?

Yes, and I tried with different CS pins.

on my ESP32 DevkitC, I tested both SPI0 and SPI1 with no problems, I suggest you check the board you’re using for fault.
Do you have other supported boards to test the code?