Problem with NodeMCU ESP-32S

Hi All,
I just started my adventure with Zerynth. After installing all things according to guidance available everything seemed to work fine but… When I upload first, the simplest code (LED blinking) to the board it doesn’t start as long as Console is closed. When I open Console, after couple seconds program starts (LED is blinking). When I close console again program stops (LED stops blinking). I think this is not as it should be. Do you have any idea what could went wrong?

Hi @sp6uni
This is very strange behavior, Does this behavior also happen with other examples?
Do you have any other NodeMCU board that you can try the example on?
Could you also try to re-register and re-virtualize the board again and try the blink example again?


thank you for your replay. Unfortunately I don’t have another NodeMCU board to check if the same problem exists there. I did re-register and re-virtualize already but these actions didn’t solve the problem. I tried other programs (examples) and behaviour is the same. I did some tests and I came to result that when program is stopped (because Console was closed) I can run it again when I plug off and then on USB cable. Seems that the NodeMCU is forced to reset itself and hold when Console is closing.

Please let us look at this behavior on the board and I’ll let you know the updates of this issue as soon as possible.

Hi. I’m have similar problems with DOIT ESP32. Board doesn’t start as long as Console is closed.

Hello Alex and sp6uni,

there is a little bug in both devices that we already fix and it will be available on next hotfix/release.
If you need this problem solved now you can manually modify 2 source files otherwise you can wait the next hotfix.

Please let me know :slight_smile:

Hello Matteo,

thank you for action and info. I can wait until release.

all the best
Mariusz, sp6uni

Hello sp6uni,

new hotfix including the bugfix of your issue is available.
Please let me know if this will solve the problem.