Problem virtualizing an Arduino Due


#1
I got this error when trying to update the VM of a Arduino Due board (currently VM is version 2.0.4 but not more compatible with last Zerynth Studio)

[info] Starting Virtualization...
[info] Auto scan for device failed
[info] Try specifying a serial port with the '-p' option
[error] Error in virtualization Auto scan for device failed
Try specifying a serial port with the '-p' option

Where and how to add this -p option ?

Thanks in advance

#2

Hi Christophe,

You have to update your instance of Zerynth Studio to last available version (r2.0.10) and, after that you have to install the last available patch (p03).

Here you can find how to migrate to r2.0.10 with new installer (https://docs.zerynth.com/latest/official/core.zerynth.docs/migration2/docs/index.html)

Now you have to create new VM for your Arduino Due and virtualized again your device.

If the “-p option” issue appears again you have to press the onboard erase button before virtualizing.

Hope this can help you :slight_smile:


#3

Hope this thread isn’t too old. I have the same problem. I just installed the latest version of Zerynth, I’m on V2.0.11-p01, under Linux Mint 18.3. I have virtualised the board before under an older version of Zerynth, but now the exact same error as Christophe had is occurring. 
Thanks,
Ian


#4

Hi mogplus8,

You have to press the erase onboard button before the Registration and Virtualization phase.
Let me know if this can help you :slight_smile:


#5

Hi Matteo, yes that fixed the problem. The main problem was that I couldn’t find the erase button! I’d seen a couple of other posts about Due’s without an erase button, and I thought mine was one of them, as I just couldn’t find it. But then I searched again (for the tenth time…) and finally found it. Another senior moment  :slight_smile:
Thanks, Ian


#6

Hi,
I have the same problem. I tried with erase button, but nothing. In “Device info” section I read all information, but I can’t to virtualize my Arduino Due. How I to do ?


#7

Could you please put the console output when you try to virtualize the device?