Particle Photon Missing symbols


#1

[info] ########## STEP 4 - generate binary
[info] Saving to C:\Users\Jacques Dufresne\zerynth2\tmp\zstudio.vbo
[info] Compilation Ok
[warning] This project has configurable options!
[warning] Options for module broadcom.bcm43362.bcm43362 ::
[warning] ZERYNTH_SSL disabled
[info] Searching for device 005d62060656f0058d04e52f147a808772caff82 with alias zs:particle_photon:005d62060656f0058d04e52f147a808772caff82
[info] Please reset the device!
[info] Searching for device 005d62060656f0058d04e52f147a808772caff82 again
[info] Probe sent
[info] Got header: r2.1.1 fnhCtFTVTlS1lGx_pA77wQ particle_photon e100d2004174433383336333 ZERYNTH
[info] Found VM fnhCtFTVTlS1lGx_pA77wQ for particle_photon
[info] Handshake
[info] symbols: 3
[info] membase 20003988
[info] romstart 08040000
[info] flash 000C0000
[warning] There are 3 missing symbols! This VM does not support the requested features! [‘atoi’, ‘atoi’, ‘strcmp’]
[error] Check if the device is virtualized with the last available varsion-patch of the virtual machine

I am using the Po2 so this is the latest one what am I missing


#2

also this post gave me an issues saying I can only reference two people due to the @ symbols in front of the memory addresses


#3

from broadcom.bcm43362 import bcm43362 as bcm
from wireless import wifi

bcm.auto_init()
for retry in range(10):
try:
wifi.link(“myssid”,wifi.WIFI_WPA2,“mypass”)
break
except Exception as e:
print(e)

if not wifi.is_linked():
raise IOError

Using this code


#4

same issue here. very similar code using the bcm43362.


#5

I’ve tried with a few variations still no luck I even tried the Base and P1 versions


#6

replacing the new bcm driver with the old one would probably work, but im not sure where to get the old driver and i forgot which windows folders all the zerynth drivers are stored.

I had to replace my bcm driver before from a bug. Looks like another one, that needs the old driver back until they fix it.


#7

if you find out where to get that from let me know!


#8

Hi @Rykker and @Jacquesd,

unfortunately there has been a little issue with the last update but we will fix it with the next one in a few days.
In the meantime you can open the file bcm43362.py in USERHOME/zerynth2/dist/r2.1.1/libs/official/broadcom/bcm43362 and move "#csrc/misc/zstdlib.c", above ##-if ZERYNTH_SSL (line 50).

Let me know :slight_smile: