NodeMCU ESP32 not listed

FROM docs.zerynth …

  • Select the NodeMCU ESP-32S on the Device Management Toolbar (disambiguate if necessary);
  • Register the device by clicking the “Z” button from the Zerynth Studio;
  • Create a Virtual Machine for the device by clicking the “Z” button for the second time;
  • Virtualize the device by clicking the “Z” button for the third time.

I’ve updated Zerynth to the latest version, but I can not find NodeMCU ESP-32S on the Device Management Toolbar (there are Sparkfun,  Devkit, Olimex…)

Hi makerns,

You have to update also the last available patch (p04); you can check the full version of your Zerynth instance by clicking the Help --> About section in the top menu (last available is r2.0.10-p04).

To install the last available patch, you have to click the “rolling updates” button (here you can find more info about this).

To check if all works well, even without any device connected, you can check the list of virtual supported devices by clicking in the “Device Management Toolbar” the “Choose Virtual Device…” option where you can find all Zerynth Supported Devices list in alphabet order.

Let me know if this can help you :slight_smile:

Ok, that is issue. Updating Zerynth doesn’t work. Yes I know for updating process (rolling updates, restart…). Messages in the console window show “dowloading xxx / installing xxx” for many components. At the end, messages “Updating Ok” and “You must restart Zerynth to …” are displayed. 
Close - reopen Zerynth… and nothing has been changed. About sectiop shows r2.0.10-base, all files under c:\user/user\zerynth2 are old (Sep 2017, not Nov 17)… Important notice… During updating process, all files are saved into zerynth2\tmp folder… I assume that Zerynth should check new version and apply from tmp folder.
Uninstall - reinstall??? I don’t need backup anything, if reinstall will solve problem, I will do it.

mmm very weird behavior…it seems to be an issue related to the installer.
Try this:
 - download again the installer from Zerynth website
 - install only the installer (overwriting the installation when asked) --> it overwrites file inside the “C://Programs/Zerynth” folder
 - Once finished, click on run Zerynth Studio and if asked run the “rolling updates” procedure again --> this time should install new packs and move them to the right place when you restart Zerynth Studio

With this procedure, described also in our doc, you don’t need to back up anything.
The only thing you have to do after patch correctly installed is to create again the virtual machine for your devices so they will work with the new last bug-fixed version (the number of free vms consumed will not increase).

Keep me posted

Uninstall -> Install from scratch … Only this way worked

Hi makerns,

sometimes it’s the better choice  :#
Glad to hear that now it works!