No connection could be made because the target machine actively refused it


#1

WIndows 10. r2.2.0-p02
No connection could be made because the target machine actively refused it

Tried two different nRF52840 DKs. Both raised this error.
Seger Embedded studio works just fine. Nordic nRF connect has no problems.

Clearly a driver problem. How to resolve without screwing my other SDKs?

Loading settings…
Switched to auto mode
Ready!
Ok
Checking for updates…
[info] Starting temporary probe…
[info] Checking probe health…
[info] Starting OpenOCD…
GNU MCU Eclipse 64-bits Open On-Chip Debugger 0.10.0+dev-00487-gaf359c18 (2018-05-12-19:30)
Licensed under GNU GPL v2
For bug reports, read
_ http://openocd.org/doc/doxygen/bugs.html_
Warn : Interface already configured, ignoring
adapter speed: 1000 kHz
cortex_m reset_config sysresetreq
Info : Listening on port 6666 for tcl connections
Info : Listening on port 4444 for telnet connections
Warn : Failed to open device: LIBUSB_ERROR_NOT_SUPPORTED.
Warn : Failed to open device: LIBUSB_ERROR_NOT_FOUND.
Error: No J-Link device found.
Warn : Flash driver of nrf52.flash does not support free_driver_priv()
Warn : Flash driver of nrf52.uicr does not support free_driver_priv()
[info] Checking probe health…
[info] Checking probe health…
[info] Checking probe health…
[info] Checking probe health…
[warning] Temporary probe may be dead…
[warning] [WinError 10061] No connection could be made because the target machine actively refused it
[warning] [WinError 10061] No connection could be made because the target machine actively refused it
[error] Can’t retrieve chip id


#2

Hello @lamming,

take a look at our documentation for the board: https://docs.zerynth.com/latest/official/board.zerynth.nordic_pca10056/docs/index.html

Unfortunately there is an incompatibility between openocd and JLink drivers: you should go back to WinUSB using Zadig.
Let me know


#3

Hi @LorenzoR
I have exactly the same error, but I have used Zadig to change the driver and it is still not working. I tried with Nordic nrf52 and nrf52840 development boards, and both boards gave the same error. Is it possible that the driver was not successfully replaced? If so, is there any way I can check if this is the case?

Thanks


#4

Hi @Sebastian5555,

you should probably replace the driver with Zadig on multiple interfaces (all the ones “powered” by JLink driver).
If the driver is replaced successfully, you will see WinUSB on the left side.
You can attach Zadig screens if you are in doubt.


#5

LorenzoR: Thanks for the kind responses. That takes a lot of the gloss off the installation process, but I understand compromises have to be made. Also Zadig isn’t the most transparent system to get to grips with either.

May I refer other people who have this problem to https://wiki.segger.com/OpenOCD
# Using J-Link with OpenOCD

In general, it is possible to use J-Link with OpenOCD. OpenOCD handles J-Link as a dumb JTAG/SWD/… probe and only uses the very low level logic to output JTAG/SWD/… sequences. It does not make use of any high level logic etc. and therefore is much slower than the proprietary SEGGER J-Link DLL / GDBServer / … implementation. In order to use J-Link with OpenOCD the standard J-Link USB driver must be replaced with the WinUSB driver, using 3rd party utilities. There are lots of walkthroughs available on the internet.

Note: Once the J-Link USB driver has been replaced, no SEGGER software from the J-Link software package will be able to communicate with J-Link anymore. To use SEGGER J-Link software again, the USB driver needs to be switched back to its default.

Mik


#6

Hi @lamming,

thank you for sharing this material with the community.
We are working to integrate JLink official software in our toolchain and for some boards it is already partially available (i.e. Infineon XMC4700 Relax Kit).


#7

Lorenzo, thanks for letting me know it is coming. Please make a loud announcement when it’s available for Nordic uC, because I’d like to try your system in earnest, but the driver-swapping issue is just too much overhead for right now.

Mik


#8

@LorenzoR

Thanks! It seems to be working now, although I cannot open the serial port for some reason. On the device info page, the port is marked ‘‘None’’, which I think is a problem. Is there any way this can be solved?
Thanks again!


#9

Hi @Sebastian5555,

I missed your response, any news on this? Do you see the COM port from Windows device manager?