Mikroe Quail board problems with r2.2.0-p04


#1

Having problems with a Mikroe Quail board ( STM32F427 ) and Zerynth Studio r2.2.0-p04. Uplink is not working, I had to downgrade to r2.1.2 to get it to work.

Was something changed in 2.2 that broke this?


#2

Hi mlimata,

Have you tried to virtualize again with last available patch (r2.2.0-p02) of the virtual machine? maybe onboard on your Quail you’re running a VM version r2.1.2 that is not compatible with the Zerynth Studio version r2.2.0-p04.

Let me know!


#3

When I install r2.20 it comes with p-04, how to I get it to install p-02 ?


#4

p02 is the last available patch for the Virtual Machine; p04 is the last available patch for the Zerynth Studio.


#5

I tried as you suggested and the problem appears to be when the message appears to reset the board and you wait a second to long then press the reset it fails to upload. If you press reset just prior or immediately as the reset message appears it works, if you wait a second too long it fails. With r2.1.2 it was not this sensitive to timing when pressing the reset button.

Thank You for your help.