Installs but fails on start


#1

When I do the install there are no issues but when I try to start the app it fails with the error:
Item to be inserted into menu already is in another menu

Model: MacBookPro13,3, BootROM MBP133.0226.B23, 4 processors, Intel Core i7, 2.6 GHz, 16 GB, SMC 2.38f7
Graphics: Radeon Pro 450, AMD Radeon Pro 450, PCIe, 2048 MB
Graphics: Intel HD Graphics 530, Intel HD Graphics 530, Built-In
Memory Module: BANK 0/DIMM0, 8 GB, LPDDR3, 2133 MHz, 0x802C, 0x4D5435324C31473332443450472D30393320
Memory Module: BANK 1/DIMM0, 8 GB, LPDDR3, 2133 MHz, 0x802C, 0x4D5435324C31473332443450472D30393320
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x15A), Broadcom BCM43xx 1.0 (7.21.171.126.1a2)
Bluetooth: Version 5.0.4f18, 3 services, 17 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
USB Device: USB 3.0 Bus
USB Device: iBridge
Thunderbolt Bus: MacBook Pro, Apple Inc., 19.6
Thunderbolt Bus: MacBook Pro, Apple Inc., 19.6


#2

Hi Anthony,
on Mac if the installation succeeds you should find Zerynth App and Zerynth Studio under Applications.
Zerynth App must be ignored (is there as support for ZStudio), and running it may give that error. To start the IDE you have to run Zerynth Studio.
If this does not solve your problem, can you please post here your operating system version?





#3

Apologies for not being clear on this. I am talking about Zerynth Studio not Zerynth App. I say app as it is an application installed on the computer. The OSX version is 10.12.5.


#4

Hi Anthony,

sorry for the late answer; unfortunately we cannot replicate your issue in our MacOS machine.
We complete the installation in OSX version 10.12.5 from scratch and all works without errors.

Have you more than one user in your MacOS machine? if yes, there is an active Zerynth installation related to other users? if no, has your user particular permission resctrictions? 


Keep me posted


#5

That’s a possibility as I am using a laptop provided my my company to test this and I am not aware of how much is restricted on the system. I will attempt to do the install from the local admin account and see what that does.


#6

Same problem about my MacBook Pro with El Capitan ver 10.11.6 (same as my son with Maverick version).
Is a problem of OS? Need help. We try to install with Win version but we need OS version working. Can you help us?


#7

Hi Alberto,

Can you report your error log please?
As mentioned before, have you, on your MacOS machine, more than one user? or permission restrictions in your user?

Let me know :slight_smile:


#8

Unfortunately I still get the same issue when installing and running as the local admin account that does not have the restrictions that a network account does.


#9

The problem we have occours in two different Mac Pro: in both cases the program exit in a unexpected way as soon the green windows open.
My Mac has El Capitain version, my son works in a different Mac pro with Maverick version. Tonight I’ll provide complete info of the error as soon as I’ll arrive at home.


#10

Still one thing. No restriction are applied and we work as administrator


#11

Here the message when app stops on Mac pro.

I try to install also on 64bit Windows PC. The installation finish ok but when I launch the first time the app it stops during the upload of the library (tested in online and offline).

So either in OS X either in Win64 we are not able to work.
Can you help us?
Regards


#12

Here the log when installation stops in win64.
The PC has Win 10 ver 1703 build 15063.483


#13

Hi Alberto,

Regarding the issue related to installation on Windows 10 machine, internet connection is always required also for offline installation (it only helps to speed up the installation skipping the package downloading phase); ZerynthInstaller.exe must be executed from your main disk (same where your Windows distribustion is installed).
By pressing F12 during installation phase, you can open the js console where more verbose log messages are shown.

Regarding the MacOS problem, we installed successfully Zerynth Studio in Sierra and El Capitan distributions so we cannot replicate the issue. Reading from your and @Anthony’s log, it seems like Zerynth Studio application menu generation in your machines is the cause of the crash.
Opening “~/.zerynth2/dist/r2.0.9/studio/zjs/app.js” file, you can find from line 77 to line 161 Zerynth Studio application menu definition.
You can try to comment or rename label names and start Zerynth Studio to discover which “Item to be inserted into menu already is in another menu” as descibed in your error log. Here below an example of change:


//submenu.append(new nw.MenuItem({label:“About”,click:()=>{Dialogs.modal(“AboutModal”)}}))
//menu.append(new nw.MenuItem({label:“Help”,submenu:submenu}))

or


submenu.append(new nw.MenuItem({label:“ZAbout”,click:()=>{Dialogs.modal(“AboutModal”)}}))
menu.append(new nw.MenuItem({label:“ZHelp”,submenu:submenu}))

<span><span>In the mean time, as soon as possible, I try to prepare for you a new app.js file to better debug this issue and if you don't succeed to solve with previous advices, we can try this other way.<br><br>Please try again both installations and let me know the results.</span></span>

#14

Many many thanks. As soon as return home thursday I’ll try and let you know


#15

Regarding win64 I provide you in my post of yesterday the install log in txt file. It is not necessary pressing F12 due to the fact that the installation stops at the point shown by the log.
You can see from this file the installation history


#16

Sorry, my bad.
I missed it and I saw only the MacOS error log.  :#

So you confirm me that during Windows installation you had an internet connection active?


#17

Yes I confirm and I disabled firewall and antivirus avast pro too.


#18

Any new about problems?


#19

Found the problem for the unexpected exit on Mac. The problem is the line:
app.update_uninst_menu() in app.js
when commented program start
pls have we problems if comment this line?
Let me know


#20

I try to work with Studio opening without the line commented (see post overthere).
If I connect particle photon it does not appear in the list of Targets.