Installation Issues

Hi i am Mua laurent computer engineering student and i am fund of python. I was just so wowed when i discorvered Zerynth cause it is what exactly i have been thinking of that is programming embedded sys using the python language

Rapindly, i installedf zeryth i am on debian (linux) but when i run it, it keeps on giving this problem. Any help would be greatly appreaciated i have wa down the tutorials and seen the syntax i just cant wait to begin my first code.

ERROR : [13107:13107:0228/] Failed to load node library (error: cannot open shared object file: No such file or directory)

Hi Mua,

this is very weird behavior; have you performed the installation as sudo or root user?
Have your user the rights to create new folder and files in the home directory?

Try to install Zerynth again as non-root user.
Let me know if this can help you :slight_smile:

Hello @“Mua Rachmann” ,

thanks for the report and for your refreshing entusiasm :smiley:

A couple of questions:
- is the debian version you are using 32bit?
- can you please verify the permissions as indicated in this github thread for NW.js (the browser used for the installer and for Zerynth Studio)

I suspect it is some Debian configuration issue not allowing to load shared library from a user directory.

I am using ubuntu 16 but yet keeps giving me the same error

Oops i guess i had it all wrong. Must i have a 32 bit OS installed??? If so then i guess i know where my problem is from thanks @Giacomo

Hi @Mua_Rachmann,

Zerynth Studio and Toolchain run only on 64bit platforms, this was the reason for Giacomo’s question :wink:

Furthermore I think that Giacomo was right in pointing to a permission issue: since it seems that a similar situation has already been solved in the past (Ubuntu 16.04 installation problem), I suggest you to try removing .config/Zerynth folder and installing again as normal user.

Let me know :slight_smile:

kk @LorenzoR will try that and get back to u