Install issues of Zerynth Studio on Catalina OSX

Hi everyone,
We have updated the Mac installer of Zerynth Studio.
If there are any other issues, Please let us know. :smile:

Just FYI
Today downloaded latest Zerynth 2.4.0 on catelina.

I STILL HAVE TO RUN THE xattr -cr COMMANDS !!!
IF NOT I AM BACK TO THE “This Application is Damaged Throw it in the BIn” MESSAGE.

Thought you had sorted out the installer for OSX ???
Not yet it seems

Mid dec 2019 I installed Zerynth for the first, without success.
Looked at the forums and noticed there were a lot of problems with the installation on mac OS catalina.
I didn’t have much time so I let it for what it was.
We are now feb 2020, I’m on mac OS catalina 10.15.3 (iMac), just installed Zerynth 2.4.0.
Solved the problem with privacy with Mac OS.
No error messages, but when I start up the application I get the Zerynth icon in the dock and in the menu bar a the top I get : Zerynth - Edit - Window tabs.
Under Zerynth : About nwjs - hide nwjs - hide others -show all - quit
Under Edit : everything is grayed out.
Under Window : everything is grayed out
No error messages.

Am I missing, forgetting something ?
I see the problems with Catalina are not solved yet ?
In fact in the forums I see there are many issues with the installation of Zerynth.
Is it us ? I installed and used STM32CubeIDE and MCUXpressoIDE this weekend without problems.
Is there a conflict with another program ? I have also visual studio code ( with platformIO ), Xcode, NectoStudio, MbedStudio installed on this machine. No problems with them.

In the getting started on the Zerynth site :
“Download Zerynth Studio and create a Zerynth Account to receive free licenses of the Zerynth Virtual Machine.”
Where do I have to create the account ( is this the same as for the forum ? )
Perhaps make it a link “create an account”.

My last question is : Is there somebody where Zerynth is working on Mac OS catalina without running commands in the terminal?

I must say I read very good things about Zerynth ( all on windows ? ), otherwise I should not have installed it a couple of times.

Thanx in advance.

hi @w1bworx
We’ve just tested again the mac installer and faced no issues on our test devices of Mac OS, We couldn’t replicate your problem.

Do you have the latest installer of the latest version? not just updating an existing version?
If not, could you uninstall the application and download the latest installer?
Then please let me know some info so I can try to replicate the problem, does it even run for instance.

Hi @technoman
You can create an account using this guide.

Could you post a screenshot of the application when you open the device?

Hi Karim,
Sorry for the late response and thanx for your concern.
Some screenshots :

image

Screenshots show startup version.
Icon appears in the dock.
And the menu bar from Zerynth is all I get.
Also other programs successfully installed on the iMac ( Catalina last version ).

I now see I can only upload 1picture, so I try to split over replies.

Best regards,
Technoman.

image

image

?!’;:= sorry only 3 replies.
??? Never experienced this before.
Only 1 pic, only 3 replies and asking for screenshots.