Install issues of Zerynth Studio on Catalina OSX

Hello same problem here. Just downloaded installer and installed version r2.3.2

unfortunately it doesn’t work.
I formatted the mac and started over. (it was something I wanted to do for a long time and I took advantage of it)
But the problem is still there!
I have also tried: sudo spctl –master-disable
I dowloaded the Zerynth form the web side again and I installed another version but I always get the same result.

I have no more ideas

More on this … My Mac has been updated to Catelina [OSX 10.15] from MoJave [OSX 10.14].

Can’t get ANY version of Zerynth Studio to run. I have r2.2.0 and r2.3.0 both of which worked before.
Tried installing r2.3.2 as a fresh installation … still the same.
Initial Launcher screen loads but clicking Start for any version produces the “Zerynth App is Damaged” Dialog as shown above by Lukas_Csizmazia.

good to know that I’m not the only one!
I’m really hope that we can get support form Zerynth.

I also have the same problem after upgrading my mac to Catalina…

any update from ZERYNTH???

No info… no email… no support
I’m moving to Micropython!

Look Zerynth Guys this is a SERIOUS problem … in effect we can no longer use your product.
Some attention !?!
some confidence that you might actually be looking into it !?!

Hi everyone.

I’m sorry for being this quiet for this long, but we are still working on this problem.

As a temporary solution you can run this command:

xattr -cr /Applications/Zerynth\

to remove the attributes from the files which are causing this issue.

This is an error caused by new policies enforced by CatalinaOS and older version of nwjs are having similar issues. This will be fixed in the next release.

Thanks for your patience,

Lorenzo Marsicano.
Software Developer at Zerynth.

Well great but unfortunately this still doesn’t work for me.
I tried removing an Reinstalling everything but no difference.

I do get an error when running the command however …

xattr: No such file: /Applications/Zerynth
xattr: No such file: /Applications/Zerynth
xattr: No such file: /Applications/Zerynth

These appear to be links to something in /Users/giacomo/miniconda3 …
Dont think I’m going to find that on my machine

Same error, no use those guys are too slow to respond.

Hi Everyone,
We are very sorry for this delay in response, We are apologizing for this unacceptable experience that you are currently having with Zerynth Studio on Mac OS.
As of right now, We are working on this problem with the highest priority and we will be updating this thread with the solution as soon as possible.

Karim Hamdy
Zerynth development team.

Hi everyone.

I apologize, but I did a mistake in my previous post. The correct commands should be the following:

xattr -cr ~/.zerynth2/sys/browser


xattr -cr ~/.zerynth2/sys/python

We have individuated the issue and we are currently fixing it.
The fix will be available in the next release, as it is now you can use those commands as a workaround.

Lorenzo Marsicano
Zerynth Development Team

Thankyou for this
… that has sorted out the main problem so Hooray I can finally load !!!
But there is definitely more to do.

I mainly work with esp32 [Pycom boards] so when I tried to compile had many complaints regarding files from unknown developers that could not be verified…
[xtensa-esp32-elf amongst others]

I opened up OSX Security & Privacy preferences and authorised all of these files as they came up … quite a lot of them it turns out but everything running OK now.
At least I think … the code builds OK which is as it was before but I don’t have a board here to test an upload. Will try and do that tomorrow.

Working on mac OSX catalina 10.15.1, installed Zerynth, nothing worked.
After entering this commands xattr ( and also getting 3 errors in /python/bin like ‘w1bworx’ ), installed Zerynth again.
Now it’s starting up, I mean there is an icon appearing in the taskbar, but further nothing.
Missing something ?
(On windows 10 VM i’m having problems with the installation screens (pop-up’s), background-color and font-color the same ? Problems with font-type ? I see the buttons and boxes but no text.)

Thanx in advance.

Problems in windows 10 VM are solved, just problems on my system due to display-settings ( 2-screens ) in VM.

Hello zerynth team,

same issues, not able to open the app on catalina.

Clicking the zpp icon will open this and vanishes after sometime. Nothing happens after.

Is there an upgrade? or did I miss something?

This happens after I use the cmds you shared?

Oh, I thought Zerynth team is active on this forum!

hi @Sree
Does the same errors persists when you open the app after executing the commands?

Hi everyone,
We have updated the Mac installer of Zerynth Studio.
If there are any other issues, Please let us know. :smile: