Infuriating....Photon & Zerynth


I’m trying to load a simple BLINK program.  It may be my ability to follow the tutorial, they are difficult to follow.  

I have registered
I have virtualised
BUT I CAN NOT UPLINK.  I get this message: "[error] Device has no serial port! Check that drivers are installed correctly…"

Do I need the put the photon into DFU mode and uplink?  This is what I have been doing…

Is there a video showing exactly what to do?  I have managed to use the IDE for the photon ok but I’d prefer to program in Python.  Help me


Here you can find our documentation where a step-by-step instruction sequence for Particle Photon driver installation is described for all platforms.

To Register and Virtualize the Particle Photon you have to put it into DFU Mode.
To Uplink your firmware, the Particle Photon must be in Standard Mode.

Until your machine doesn’t recognize the serial port of the device, it’s impossible to uplink the firmware; you can check if your drivers (both for Standard and DFU mode) are correctly installed by clicking on the ‘info’ button alongside the device management toolbar and see if the “Port” field is not None.

Let me know if this can help you.


Well, I tried and tried and FINALLY i got the uplink to work.  Not sure what I did, but part of the answer is the flicking of the reset button, it is quite sensitive to timing.