I2c library does not work

Board : esp32 Vroom DevKit
I have tried to use the i2c.py library from the examples.

Using the class
import I2C
i2c = I2C(I2C0,29)
and trid
i2c = I2C(0,29)
it always comes back
[Thread 1 exited with exception TypeError @[008E:00DD:0000:0050:0000:0000:0000:0000]](javascript:window.except(’@[008E:00DD:0000:0050:0000:0000:0000:0000]’,'Thread 1 exited with exception TypeError '))

After looking at the adc.py exmaple I have also tried to rewrite as a none class version adding a few globals - dropping self. etc
Here I get a porblem with
drv = __driver(drvname)
in the init function where it always just hangs.
(see the i2c.py example init :
def init(self, drvname, addr, clock=100000):
self.clock = clock
self.drv = __driver(drvname)
self.drvid = drvname&0xff
self.addr = addr
the double underscores were removed frominit on posting !
)

Any ideas why I am having problems with this library.
Is there an easy solution. I would love touse hte zerynth to drive I2C devices.

Could you try: D29
I2C(I2C0,D29)
Could you click on the error and tell me which lines causes the error

The number 29 is hte address for the I2C device and should be a number - I tried D29 and it makes no difference.
Now I am seeing this.

Thread 1 exited with exception TypeError @[008E:00DF:0000:0050:0000:0000:0000:0000]

The error just points to the main routine.
I found the problem with __driver ny trial and error

I don’t belive thisworks.
I will need ot move on and use a more reliable source.

Perhaps its easier to give you an example of using the I2C
Please have a look at BME280 example, it uses the I2C
https://docs.zerynth.com/latest/reference/libs/bosch/bme280/docs/examples/