Hexiwear (under Windows 10)


#1

Greetings, I have reviewed this similar topic, issue registering Hexiwear from a MacOS. However I have the problem on a WIndows10 host. I cannot register my device, that was well recognized in Zertyth Stusio, as correct device info was provided.

On device registration, the console shows:

[info] Starting device registration
[info] Burning bootloader...
[info] Burning bin
Does D:\hexiwear.bin specify a file name
or directory name on the target
(F = file, D = directory)? f
C:\Users\username\zerynth2\tmp\tmp_od645k0\tmp.bin -> D:\hexiwear.bin
1 File(s) copied
[info] Please reset the device!
[error] Can't open serial port!

I did reset the device as advised with no avail. The error says "Can’t open the serial port!’. I verified in WIndows device manager that the port is there: it shows “mbed Com Port (COM5)”. However I could not open COM5 from TetraTerm either.

Thanks for your help!
JP


#2

Sorry, problem solved. I did not notice that I had a TeraTerm (terminal) session up and running, that was holding the COM port. INdeed closing this terminal, and re-trying the registration, just worked.

Thanks,
JP