Hexiwear example doesn't run


#1

After all the virtualization, etc, the Hexiwear example code freezes after printing “init” and “start”.  Is something up with the Nxp library?


#2

Hi scotttetrick,
this is a known issue of that example, unfortunately we have not fixed it yet, but you can try the following workaround: https://community.zerynth.com/discussion/comment/1430/#Comment_1430

Let me know if it works for you :slight_smile:


#3

It also worked to comment out the 
# hexi.fill_screen(0xFFFF,False)


#4

Glad to hear, we will fix this example ASAP and will be available in future patches :wink:


#5

Tried following the instructions above, but still get a blank screen (with LED shining blue) on the Hexiwear. Any ideas?  


#6

Hi archishealth1,

Hexiwear device has a known bug in resource usage especially when has to display many screens; we’re already working on it.

You can try to comment every line about the screen management and check if, in your serial monitor, you can see all measurements from Hexiwear internal sensors working properly.

Then you can test which instructions, from those commented, caused the bad functioning (by uncommenting one by one and uplinking again the script).

Let me know if this can help you :slight_smile: