Hexiwear [error] Can't find chipid when trying to register device on Mac


#1

I just got my Hexiwear and downloaded Zerynth on Mac.
I follow the instructions https://www.zerynth.com/blog/programming-hexiwear-wearable-iot-in-python-using-zerynth/,
but I keep getting the [error] Can’t find chipid.

Here is the exact output:

[info] Starting device registration
[info] Burning bootloader…
[info] Please reset the device!
[error] Can’t find chipid

I’ve tried making sure to hit RESET when prompted to. I’ve confirmed that the Hexiwear Docking Station is recognized by my machine. I’ve also read this thread: https://community.zerynth.com/discussion/497/error-connecting-hexiwear-by-nxp


Can someone help me?


#2

Can someone also let me know how I should have the switches set on the hexiwear doc k as well?


#3

Hi Anjian,

By clicking the ‘info’ button with the device connected to your machine, did you see the serial port field different from None? and disk field?

Have you tried to open the serial monitor and see if something is printed?

Regarding the switches, the correct positions are:

Up, Up, Down, Down, Up, Up, Up, Up (from left to right)

Let me know :slight_smile: