Help to install on linux


#21

Hello,
Happy new year!,

I’ve updated all the drivers with Windows7 64 bit (no my pc) and finally i viperized the board
I tried uploading “hello world” but tells me:
Can not open board @
[UPLOAD]: ooops, uploading failed with the following error: Can not open serial!

I tried all usb available but without success …




#22

Hi!
using an evaluation license of Windows 7, I tested viper on my pc.
All works (viperize and upload sketches)!


Unfortunately I do not have a permanent license for seven, and I have to go on linux.
With ubuntu I could not make it work, I tried with mageia 5 but does not work with files .sh


Someone please tell me which distro definitely works with Viper?

Thank you


#23

Hello Walter,

If you have viperized the Nucleo in windows 7 you should have no problem using it in Ubuntu.
I use Arch Linux for development and testing and everything works… but the installation and maintenance are not as user friendly as Ubuntu…


#24

Hello Giacomo,

with Ubuntu or other distros on my pc viper is not working.
I found, perhaps, a PC of my friend with windows 7.
I will use the PC for my tests.

Thanks again



#25

Easiest way to install is to uncompressed the downloaded package into a directory, say /home/rob/Temp/, then move it to the /opt directory.

sudo mv Viper/ /opt

Inside the /opt/Viper directory you can execute the viper.sh script by:

./viper.sh

Later you can add a desktop launcher once you have tested it.


#26

hi borris!

thanks!

in this period i’m not at home and i can’t try that you have suggested.
When i return, i try

thanks again


#27

hi borris!
i try with your system and it works!
it’s very simple, thanks.
unfortunately the result does not change.
I can not  upload a code on a stnucleo viperized with windows7.

Thank’s 
again


#28

I have ubuntu 16.04, I have downloaded zerynth.tar.xz and extracted its components. However, I did not find viper.sh, and I dont know how to use zerynth, any help ?


#29

Hi minamaged113,

Here a link of our documentation where you can find a step-by-step tutorial of the installation sequence.
In other sections of the documentation you can learn all you want to know about Zerynth :wink:

Hope this can help you.


#30

hi…can anyone helpme out…I have installed zerynth in ubunttu 18.0 version.I dont know how to start the IDE.Files are extrace into desktop in the name of zerynth.then wat to do??


#31

Hi sathish,

try running again the zerynth executable file from the folder you used to install the Studio.
Let me know :slight_smile: