Help to install on linux


#1

Hello,
my name is Walter and I live in Belluno, Italy.

I’m newbie in Viper and linux, I downloaded the package for Linux 64 but I do not know how to install. Is there a tutorial? or someone tells me how can I do?
Thank you!


#2

Hello Walter,

The package is a tar.xz archive. You should be able to open and extract it with most of the Linux distributions without installing any new program. If you tell us what’s your Linux distro, I can point you to more detailed instructions.

Once extracted, you can double click on the viper.sh script to run the Viper IDE. 



#3

Thank you!
My distro is ubuntu 15.10.
I extracted the files tar.xz and I created the folder Viper.
I found the file viper.sh.
With double click I open gedit text editor, I can not start the IDE.
Thank you very much, it is the first time I use linux because viper 32bit for windows is not available.


#4

ooops, Ubuntu is configured not to run shell scripts as a default action.
Follow the instructions here to override such behaviour.

I guess I will add a .desktop file in the next update to avoid this issue.



#5

ok, thank’s!
I begin now to use Linux, if you believe that another distro is best for viper, I can install the distro that you indicate me without problems



#6

Don’t worry, Ubuntu is ok :slight_smile:

The next step is to let Ubuntu recognize your boards. Linux distributions have a program called “udev” that is in charge of recognizing hardware events and do something after them, like for example installing/uninstalling your pen drive when it is plugged/unplugged. 

The same must be done for your boards. The procedure is easy:

  • Open a terminal
  • Open a new udev rule file by typing in the terminal: sudo gedit /etc/udev/rules.d/99-viper.rules
  • Type the rules in gedit (see below)
  • Save and close gedit
  • tell udev to reload the rules by typing in the terminal: sudo udevadm control --reload-rules
Every command with “sudo” will ask for root password.

And here are the Viper rules for all the boards:

#ST Nucleo
SUBSYSTEMS==“usb”, ATTRS{idVendor}==“0483”, ATTRS{idProduct}==“3748”, MODE=“0666”, GROUP="users"
SUBSYSTEMS==“tty”, ATTRS{idVendor}==“0483”, ATTRS{idProduct}==“3748”, MODE=“0666”, GROUP=“users”
#Particle Core
SUBSYSTEMS==“usb”, ATTRS{idVendor}==“1d50”, ATTRS{idProduct}==“607f”, MODE=“0666”, GROUP=“users”, ENV{ID_MM_DEVICE_IGNORE}="1"
SUBSYSTEMS==“tty”, ATTRS{idVendor}==“1d50”, ATTRS{idProduct}==“607f”, MODE=“0666”, GROUP=“users”, ENV{ID_MM_DEVICE_IGNORE}="1"
SUBSYSTEMS==“usb”, ATTRS{idVendor}==“1d50”, ATTRS{idProduct}==“607d”, MODE=“0666”, GROUP=“users”, ENV{ID_MM_DEVICE_IGNORE}="1"
SUBSYSTEMS==“tty”, ATTRS{idVendor}==“1d50”, ATTRS{idProduct}==“607d”, MODE=“0666”, GROUP=“users”, ENV{ID_MM_DEVICE_IGNORE}=“1”
#Particle Photon
SUBSYSTEMS==“usb”, ATTRS{idVendor}==“2b04”, ATTRS{idProduct}==“d006”, MODE=“0666”, GROUP=“users”, ENV{ID_MM_DEVICE_IGNORE}="1"
SUBSYSTEMS==“tty”, ATTRS{idVendor}==“2b04”, ATTRS{idProduct}==“d006”, MODE=“0666”, GROUP=“users”, ENV{ID_MM_DEVICE_IGNORE}="1"
SUBSYSTEMS==“usb”, ATTRS{idVendor}==“2b04”, ATTRS{idProduct}==“c006”, MODE=“0666”, GROUP=“users”, ENV{ID_MM_DEVICE_IGNORE}="1"
SUBSYSTEMS==“tty”, ATTRS{idVendor}==“2b04”, ATTRS{idProduct}==“c006”, MODE=“0666”, GROUP=“users”, ENV{ID_MM_DEVICE_IGNORE}=“1”
<div><br>Udoo and Arduino Due are recognized automatically because they use an ftdi chip.</div>

#7

hi,
I did as you told me,
1) when you tell udev to reload the rules, will not ask for root password. Is ok?

2) if I double click viper.sh, start a browser windows Viper IDE and tells me:
“The SERVER is not responding !! Please restart the IDE”

3) when I plug stnucleo opens a windows NODE F401RE

I tried to download a second time the ide, but nothing has changed,

thank’s a lot!


#8

mmm…

1) ok

2) very bad: I’ll check on an ubuntu installation and let you know

3) ok, it should be the ubuntu automount



#9

OK thanks!
these days I have tried many times:
when you double click on viper.sh, the browser (firefox) opens and tries to connect to “http://127.0.0.1:5566/ide/index.html” and tells me:
“The SERVER is not responding !! Please restart the IDE”


#10

Here I am @Walter…with bad and good news.

I tested Viper on a fresh ubuntu install (in a virtual machine) and was able to reproduce your problem. 
Here is the so@Walter 

  • open a terminal
  • type: “sudo apt-get install git” 
  • once finished type: "sudo apt-get install gcc-multilib"
  • once finished change your current directory to the Viper directory (the one with viper.sh inside). In my case it was in Desktop/Viper so I typed: "cd ~/Desktop/Viper"
  • change directory to the Viper git directory: "cd sys/linux64/git"
  • remove git: "rm git"
  • substitute with installed one: "ln -s /usr/bin/git git"
  • start viper
The problem is twofold: the git executable shipped with Viper needs some libraries not present in Ubuntu by default; also, the gcc compiler for arm microcontroller is 32bit only, therefore gcc-multilib is needed.

Let me know!

#11

Hi!
bad news,
I followed your precise information for 2 times, no errors found,
but viper always tells me “The SERVER is not responding.”
My installation is new and updated, I installed only viper waiting viper 32bit for windows …
Maybe
Ubuntu is not my  distro … any suggestions for another distro more compatible with viper?
thanks and sorry



#12

no one can tell me which distro runs smoothly with viper?


#13

Hello @Walter,

please, try to download again the linux installer, I should have fixed the problems in Ubuntu.


Let me know!


#14

ok it works! thank you!
to launch it, I open the terminal and I type “./viper.sh”
(the procedure which you said does not work … the git directory no longer exists in the new release)
The ide start, but when I try to viperize, tells me:
“Error while viperizing viperizing Error: error: [Errno 28] No space left on device”
Thanks again!


#15

Nice!

For the viperization error, are you using a ST Nucleo f401?


#16

Yes!
F401RE,
ide recognizes it as Physical Board




#17

mmm…that Nucleo message stinks of old firmware.

Can you try to update the Nucleo firmware as described here?
You could do it easily from windows.

Let me know!


#18

Hello,
I upgraded the firmware today, unfortunately, the error message is still the same


#19

Mmm… I can’t reproduce the issue on my ubuntu virtual machine…

however, try this to viperize manually:

  • plug the st nucleo and select it as current board
  • click on the viperize button
  • in the dialog that opens, click the orange button "Get Binary"
  • depending on your browser two things can happen: a file with a strange name is downloaded or a page with strange symbols is opened.
  • In the first case, rename the downloaded file to "nucleo.bin"
  • In the second case, right click on the page and choose “Save Page As”, save the file somewhere naming it "nucleo.bin"
  • copy nucleo.bin to the nucleo volume appearing on the “Files” windows (see screenshot below)
  • The nucleo LD1 led should blink red and green for a couple of seconds, then the LD2 will blink just green for two seconds. That’s the sign of correct viperization.



#20

bad news,
when I try to copy the file nucleo.bin, he tells me that the device has no space.
I’ve updated all the drivers with Vista, when I try to copy nucleo.bin tells me the same error.
I try the manufacturer’s website to find a solution.
Anyway … Merry Christmas to all the community and thanks again!
Walter