Help me to use ZERYNTH

Goodevening everyone,

I am interested in using ZERYNTH for simple hobby home automation circuits (garage alarm, sensor temperature humidity, etc).

Next to the sixty I'd like to start using Python and ZERINTH project, I find it very interesting.

After downloading :smile: 

Zerynth Studio

I installed it and unfortunately I have this message:

"Can not download repository"

that does not allow me to continue.

I have a doubt, if the corporate PC I'm using has the proxy how can I get around this ?

Tonight, I tried to install ZERYNTH STUDIO on my own PC (no proxy) but unfortunately does not have a 64bit architecture.

I have to give up?

How can I get out of this constraint ?

Thanks for any suggestions



TOC, TOC, TOC … all still got to the “bridge of the dead” (in ITALY)? For the 32 bit problem I understand that there are no answers, but I think for the proxy is not the only …  :slight_smile:


We only support 64bit OSs for the Zerynth IDE. 
The only things I can figure out for allowing you to use Zerynth on a 32bit machine is to install a 64bit OS on a virtual machine like VMware… it should be able to virtualize 64bit OSs on a 32bit machine… but I never tried it  :|

For the problem of the proxy, in the next release of the Zerynth Studio it will be possible to download all the required packages as extra installation file allowing an offline installation of the entire suite. so your problem will be solved but this will be not available until Jannuary… we are sorry for this issue  :s


Dear Daniele,

thanks for the clear and comprehensive response.

Unfortunately, buying a PC with 64-bit architecture is too expensive for  my “recreational purposes”.

January 2017 is not far away … I will wait patiently for the release … or I could start testing a beta version of “ZERYNTH STUDY OFFLINE” … Bugs or crashes will be accepted with a :smile: 

What do you think? It’s possible ?

Thanks a lot



we will release the private beta of the new zerynth studio with offline installer soon… i’ll keep you posted :slight_smile:


Hello everyone, I have just downloaded ZERYNTH r2.0.0 (Beta) and tried to install OFFLINE to avoid the problem already reported previously (PROXY Company). Unfortunately, the installation is not completed successfully. In order to solve the problem I request your help by sending the ZERYNTH Installer Log :  


I replied you in the Zerynth r2.0.0 beta release and debug post