Esp32 wifi driver


#1

Hi, I’m new on it.
Try diferent example. All works except using the wi-fi library:
“from espressif.esp32net import esp32wifi as wifi_driver”
No compilation error but got this message on esp console:

SET),boot:0x1ets Jun 8 2016 00:22:57
rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
configsip: 0, SPIWP:0xee
clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
mode:DIO, clock div:2
load:0x3fff0018,len:4
load:0x3fff001c,len:3064
load:0x40078000,len:0
ho 12 tail 0 room 4
load:0x40078000,len:11504
entry 0x40078d64
E (30) boot: ota data partition invalid and no factory, will try all partitions
E (13099) wifi: wifi_init 1408 ret=4353


#2

Hi @Gheorghe_Popescu,

can you try to erase the device flash (Device Info->Erase Flash) and virtualize again?


#3

Hi, on device info Erase Flash button are missing, only Cancel, Forget, Ok, button is available.
It works with FOTA enabled VM. I’m trying to use command line from ztc : ztc device erase_flash …
that give me error.
ztc device --help is like this:

alias
db

and many other but no erase_flash

Zerynth studio r2.1.1 on Windows 10


#4

Hi @Gheorghe_Popescu,

you should update to version r2.1.2 :wink:


#5

Same happened to me.
when I run wifi_driver.auto_init()
it freeze.
the only message in the console is E (13113) wifi: wifi_init 1408 ret=4353


#6

Have you tried the reported Erase Flash procedure?