ESP32 DevkitC- NTP_Client example throws an IO error


Using an ESP32 DevKitC, I got the following error when running the “ntp_client” example:
IOerror @[003a:0020:0046:0089:0000:00B1:0000:0000]
which, when clicked on, gives the following in the output/status window
IOError at line 65 of main
raised at line 56 of ntpclient.get_time
raised at line 192 of socket.recvfrom
I have the proper wi-fi credentials patched into the program. Also, if I run the “UDP NTP Time” example it works fine. There must be something wrong with the coding in the first example- maybe the ntp time server domain name is wrong.
I just performed the Hotfix that showed up when I started Zerynth just now, but it makes no difference for this issue.


Hello bmiller,

there is a little issue in the first example that will be fixed in next release (few weeks).
You can use the second example to continue your application development and you can write if you need any other help.


Thanks- I am a newcomer- just trying out examples. I knew the UDP example worked- I was just reporting the problem with the other example to Zerynth