ESP32 devkit C is crashing in BLE examples

Hi!

I have two ESP32 DevkitC devices and I’m found that is crashing randomly while BLE is running in Studio v 2.3.2 or 2.3.3, for example, BLE_Scan:

https://docs.zerynth.com/latest/official/lib.espressif.esp32ble/examples/examples.html#ble-scanner

Sometimes it working well but crashed after few seconds:

Detected packet from 5F:D0:43:08:C0:85 containing 02:01:1A:02:0A:0C:0A:FF:4C:00:10:05:07:14:97:4E:A9

     remote device has RSSI of -89

Detected packet from 88:63:DF:B6:8F:06 containing 02:01:06:0A:FF:4C:00:10:05:01:1C:3C:4C:DA

     remote device has RSSI of -85

Guru Meditation Error: Core 0 panic’ed (LoadProhibited). Exception was unhandled.

Core 0 register dump:

PC : 0x400d3eba PS : 0x00060b30 A0 : 0x800dee4a A1 : 0x3ffddae0

A2 : 0x00000000 A3 : 0x3ffd9e44 A4 : 0x00060f20 A5 : 0x00000001

A6 : 0x0000cdcd A7 : 0x00000000 A8 : 0x800d3eba A9 : 0x3ffddac0

A10 : 0x00000000 A11 : 0x00000000 A12 : 0x3ffc6054 A13 : 0x00000000

A14 : 0x3ffc6008 A15 : 0x00000000 SAR : 0x00000020 EXCCAUSE: 0x0000001c

EXCVADDR: 0x00000008 LBEG : 0x4000c2e0 LEND : 0x4000c2f6 LCOUNT : 0xffffffff

Backtrace: 0x400d3eba:0x3ffddae0 0x400dee47:0x3ffddb00 0x400defdd:0x3ffddb30 0x401b320a:0x3ffddb50 0x40113c71:0x3ffddb80 0x4011159e:0x3ffddba0

Rebooting…

ets Jun 8 2016 00:22:57

rst:0xc (SW_CPU_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)

configsip: 0, SPIWP:0xee

clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00

mode:DIO, clock div:2

load:0x3fff0018,len:4

load:0x3fff001c,len:3648

ho 0 tail 12 room 4

load:0x40078000,len:9928

ho 0 tail 12 room 4

load:0x40080400,len:5788

entry 0x400806c0

E (32) boot: OTA: -1/-1 -1/-1 -1/-4

E (33) boot: Invalid ota, returni

Hi @avfedorov
We are going to look at this bug and let you know the updates as soon as possible.

Hi! Same thing happened to me. Isn’t there a bug fix yet?