Error while creating vm in ESP32 DevKitC


#1

I have downloaded Zerynth Studio, then I connected a esp32 devkitc with usb cable, registered it and tried to virtualize it, but i see an error like this

[fatal] Error while creating vm: vm limit reached

</span>I tried to do all the process one more time, but i get the same error.<br>Could you help me with this?

#2

Hi Fresh Flash,

we discover a bug related to this issue; we will fix ASAP.


#3

Please try it again now and let us know if it works. 


#4

No, as for me, the problem still exists.
But now I have problems with rolling updates of zerynth studio, so I can’t update it anyway.
I get errors like this when trying to update

``[error] Error while downloading lib.googlecloud.iot
It downloads and installs some libraries correctly, but then stucks at some ones.

#5

Hi Fresh Flash,

Thanks for reporting us your issue, we’re working to fix it.
Please be patient and sorry for this bad functioning :slight_smile:


#6

Hi Fresh Flash.

All Fixed!!! :slight_smile:
You can try to install again the patch by clicking the “rolling updates” button and let us know if now it works


#7

Actually, the problem is solved in a half.
Now I can install rolling updates, but problem with vm limits still exists.
I am using Zerynth for Linux, maybe it would help you

UPD: I tried to do it on Windows, but I also have the same problem with vm limits


#8

Hi Fresh Flash,

sorry for the inconvenient, now all works properly!
Thanks for your patience and happy coding :slight_smile: