Error virtualizing Pycom FiPy 1.0 board


#1

I am trying to virtualize Pycom FiPy 1.0 board, but after doing the procedure of setting the board in downloading mode, I press the button for registering the board and I get this error:

[Errno 2] No such file or directory: ‘C:\Users\AB\zerynth2\dist\r2.0.11\devices\pycom_fipy_v1\register.vm’

Can anyone tell me what is wrong? Thanks!


#2

Hi Ana,

You’re running the Zerynth Studio version r2.0.11 but the Zerynth Ecosystem is now on r2.1.0-p02 (latest release) and from r2.1.x is no more retro-compatible with r2.0.x versions.

Here more info

Try to update and then repeat the procedure to register, virtualize, and uplink your Pycom device.

Let me know if this can help you :slight_smile:


#3

I have the same issue on a fresh install of Zernyth Studio with the r2.1.0-p02 release. I’ve tried this on both Mac OS and Windows 10 with the same result, the following error messages:

Traceback (most recent call last):
File “/Users/ianhollier/.zerynth2/dist/r2.1.0/ztc/ztc.py”, line 111, in
cli()
File “/Users/ianhollier/.zerynth2/sys/python/lib/python3.5/site-packages/click/core.py”, line 716, in call
return self.main(*args, **kwargs)
File “/Users/ianhollier/.zerynth2/sys/python/lib/python3.5/site-packages/click/core.py”, line 696, in main
rv = self.invoke(ctx)
File “/Users/ianhollier/.zerynth2/sys/python/lib/python3.5/site-packages/click/core.py”, line 1060, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/Users/ianhollier/.zerynth2/sys/python/lib/python3.5/site-packages/click/core.py”, line 1060, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/Users/ianhollier/.zerynth2/sys/python/lib/python3.5/site-packages/click/core.py”, line 889, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/Users/ianhollier/.zerynth2/sys/python/lib/python3.5/site-packages/click/core.py”, line 534, in invoke
return callback(*args, **kwargs)
File “/Users/ianhollier/.zerynth2/dist/r2.1.0/ztc/devices/devcmd.py”, line 244, in register
reg = fs.get_json(fs.path(tgt.path,“register.vm”))
File “/Users/ianhollier/.zerynth2/dist/r2.1.0/ztc/base/fs.py”, line 56, in get_json
with open(src,“r”,encoding=“utf8”) as ff:
FileNotFoundError: [Errno 2] No such file or directory: ‘/Users/ianhollier/.zerynth2/dist/r2.1.0/devices/pycom_fipy_v1/register.vm’

Right now this tool seems dead in the water for my needs given that I cannot do anything if the device cannot be registered. Any idea how to fix this or do I just go back to using standard micropython and the SDK’s from Pycom.

Thanks


#4

Hi @firedog1024 and @Ana_Belen_Munuera,

It seems that for unknown reason you have not the register.vm file for Pycom Fipy v1.
You can close the Zerynth Studio, navigate under “.zerynth2/dist/r2.1.0/devices/pycom_fipy_v1/” and put the file inside the zip in the attachment (register.vm).

Now you can restart the Zerynth Studio and try again to register you Pycom Fipy v1.

Let me know if this can help you :slight_smile:

register.zip (285.6 KB)