ERROR connecting Hexiwear (by: NXP)


#1

Good Morning,

I have a Hexiwear device made by nxp. According to Zerynth guide, I was trying to program the device using Zerynth Studio and python. Unfortunately, I am unable to register the device, as an error occurs. These are the stages occurring:

Loading settings…
Ready!
Checking for updates…
[info] Starting device registration
[info] Burning bootloader…
[error] Can’t find chipid


I have tried this on a mac as well as Linux machine, both without success. This process has also wiped the Hexiwear and does not turn it on anymore.

Can anyone please let me know why this is happening?

Kind Regards,

Athar Anjum


#2

Hi Athar,

You can verify if DAP-Link interface is correctfully recognized by clicking “Info” button on Zerynth Studio top bar and checking if “Port” and “Disk” fields are not None.

Then you can try to register again and wait for “[info] Please reset the device!” msg in console log; pressing the reset button on Hexiwear Docking Station, Zerynth Studio should find the chip id to complete regiatration phase.

Let me know if this can help you :slight_smile:


#3

Thank you for your help, 

I have managed to Register it, that way. 

I have tried to upload the Hexiwear project, which is already in Zerynth studio, however it fails with an error:

[error] No answer to probe


Do you know what this could be?


#4

Hi Athar,

After registration you have to create a new virtual machine for your device and then virtualize the Hexiwear (both operations are available by clicking the “Z” button on Zerynth Studio top bar).
After Virtualization you can uplink your firmware in the hexiwear by following the popup instrucions.

 


#5

I am trying to connect using the guide provided on:

https://www.zerynth.com/blog/programming-hexiwear-wearable-iot-in-python-using-zerynth/

I have now managed to Register the Device, however when I try to create a Virtual Machine for the device by clicking the “Z” button for the second time; 

I get this error coming up:

[fatal] Error while creating vm: vm limit reached

I am then asked to create a virtual machine again, but with the same out come.

I have tried reinstalling Zerynth, but still no luck.

Can someone help me out here?



Thanks
Athar 


#6

hi,
have you updated Zerynth to the last release? 
current version is 2.0.8


#7

Hi,

I am trying to create a virtual machine.

However it keeps failing with the following error:


[fatal] Error while creating vm: vm limit reached


Does anyone know how to resolve this issue?


#8

Yes I have the most up to date version


#9

ok, we are trying to recreate the issue on our machines. we’ll keep you posted.
thanks for the feedback


#10

Hello @Athar,

I checked the server logs and it seems Zerynth Studio is asking for a r2.0.7 VM based on ChibiOS which is not usable with the current release of Zerynth (yes, I admit the error message is not the best  :D). Can you please double check  the version of your system by clicking Help --> About and retrieve the reported version?


#11

Hi Athar,

Zerynth Studio r2.0.9 is out!!! Try to update your system and create a new free virtual machine to virtualize your Hexiwear.

Keep me posted!


#12

Hello,

I get similar problem.

I installed Zerynth Studio r2.1 today.
and I tried to connect to hexiwear docking station.

I checked it virtualized and sample python code was verified,uplinked.

but I can’t connect to Hexiwear docking station.

following error occurred.
[info] Probe sent
[error] No answer to probe
[warning] Timeout! Retrying…
[fatal] Can’t get templates list
Traceback (most recent call last):
File “/Users/XX/.zerynth2/dist/r2.1.0/ztc/things/thingcmd.py”, line 495, in __templates
rj = res.json()
File “/Users/XX/.zerynth2/sys/python/lib/python3.5/site-packages/requests/models.py”, line 826, in json
return complexjson.loads(self.text, **kwargs)
File “/Users/XX/.zerynth2/sys/python/lib/python3.5/json/init.py”, line 319, in loads
return _default_decoder.decode(s)
File “/Users/XX/.zerynth2/sys/python/lib/python3.5/json/decoder.py”, line 339, in decode
obj, end = self.raw_decode(s, idx=_w(s, 0).end())
File “/Users/XX/.zerynth2/sys/python/lib/python3.5/json/decoder.py”, line 357, in raw_decode
raise JSONDecodeError(“Expecting value”, s, err.value) from None
json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)
[fatal] Can’t retrieve message list unauthorized
Error while checking for updates 1:2

maybe uplinking with reset manner is bad or python version is bad?


#13

Hi ymsyms1978,

I need more info to better understand your issue:

  • Have you succeeded to register the Hexiwear device?
  • Have you succeeded to virtualize it?
  • By clicking the “info” button with the Hexiwear connected to your machine, fields “Port” and “Disk” are different from “None”?
  • Do you try to uplink a Zerynth Example or your own application? if it is a Zerynth Example, Which one (so I try to reproduce the bad behaviour)?

Let me know :slight_smile: