Core Update 0.3.1

And here it is a new update!

The core packages are all updatable and there are also some new libraries in the pool.
The update can be performed by refreshing the package list and then clicking on the puzzle icon that will appear on the top bar:



There are many new features:

  • Standalone browser: the IDE will now use its own browser (node-webkit) to avoid platform problems
  • User libraries: special projects can be created that will behave as libraries. Each library must have a namespace that will be used to correctly import it. Libraries can also be added to the Viper Package Manager to share them with the community, after a review process. Library code will be hosted on Github on your personal account.
  • Bluetooth Smart: the package lib.adafruit.bluefruit has support for Bluefruit products from Adafruit
  • MQTT: search for mqtt in the VPM and install our official mqtt module
  • Standard Library: mcu soft reset support (mcu module), fixed spi issues, fifo module and expanded documentation for advanced topics like C language interfacing
  • Low Level Documentation: the C APIs  used by the virtual machine are now documented; it is time to start mixing C and Python to get the best of both worlds.
  • Many bug fixes

As usual if the update process does not go smoothly, you can download the full Viper installer from here.
If the package manager gets corrupted for some unfathomable reason you can restore your Viper instance by deleting the vpm_r.db  and vpm_t.db files under:

- ~/.viper/cfg in Linux
- /Users/your-user/viper/cfg in Windows
- Documents/Viper/cfg in Mac OS X

I’m not able to clone a project. If I click “Create New” (namespace) or “Create” I can’t do anything. I’m stuck in that point.

Trying to create a new project from scratch I get this error:




Maybe this is because of a “non-fresh installation of Viper”?

I tried uninstalling Viper, then deleting the viper directory in USERS/pc_name in Windows. Now I got this error while installing viper from scratch. I tried deleting “vpm_r.db and vpm_t.db” but this error comes again.


For the library creation error, a new ide package will be released tomorrow with a fix.

For the bootstrap problem, please download again the installer from here, there was a bug in the installer package list. Deleting vpm_r.db and vpm_t.db should suffice if problems arise. However being Windows filesystem very stupid peculiar, you may also need to delete the env directory (same place of cfg).

New IDE package available with WIndows fix  :stuck_out_tongue: (r0.3.3)

Possibly related issue using Linux

After trying to update the libraries I ran into some issues.  I restarted viper and during installation of the packages I received

"Installing core.viper.boards_standard

Impossible to bootstrap!  argument should be string, bytes or integer, not VpmVersion"

Associated Traceback:

Traceback (most recent call last):
  File “/home/name/.viper/env/sys/python/lib/python3.4/threading.py”, line 920, in _bootstrap_inner
    self.run()
  File “/home/name/.viper/env/sys/python/lib/python3.4/threading.py”, line 868, in run
    self._target(*self._args, **self._kwargs)
  File “/home/name/Desktop/Development/Viper/bootstrap.py”, line 118, in bootstrap_vpm_fn
    raise e
  File “/home/name/Desktop/Development/Viper/bootstrap.py”, line 105, in bootstrap_vpm_fn
    if toolbelt.vpm.install(corepkg,force=True):
  File “/home/name/.viper/env/core/official/vpm/vpm.py”, line 889, in install
    self._install_sys(pack,vrs,tdir)
  File “/home/name/.viper/env/core/official/vpm/vpm.py”, line 1048, in _install_sys
    shutil.copytree(tmpdir,sysdirs[“path”],ignore_dangling_symlinks=True)
  File “/home/name/.viper/env/sys/python/lib/python3.4/shutil.py”, line 297, in copytree
    names = os.listdir(src)
TypeError: argument should be string, bytes or integer, not VpmVersion

Everything works after downloading the new installer.