Core panic trying to use the DIgital Read sample


#1

Hi!

I am trying to read a switch, so I took the Digital Read sample, and uploaded it to my ESP32 DevKitC, and though I had been running my own project just before that all right, this project results in this:

Guru Meditation Error: Core 0 panic’ed (IllegalInstruction)
. Exception was unhandled.
Register dump:
PC : 0x40114dd1 PS : 0x00060130 A0 : 0x8010deea A1 : 0x3ffdc210
A2 : 0x00000006 A3 : 0x00000021 A4 : 0x00000002 A5 : 0x00000002
A6 : 0x3ffd923c A7 : 0x00000000 A8 : 0x80114da8 A9 : 0x3ffdc1f0
A10 : 0x00000000 A11 : 0x00000028 A12 : 0x00000028 A13 : 0x00000040
A14 : 0x00000000 A15 : 0x00000024 SAR : 0x00000007 EXCCAUSE: 0x00000000
EXCVADDR: 0x00000000 LBEG : 0x4011225c LEND : 0x401122f4 LCOUNT : 0x00000008
Backtrace: 0x40114dd1:0x3ffdc210 0x4010dee7:0x3ffdc250 0x4010c86f:0x3ffdc270 0x40108065:0x3ffdc2d0 0x4010807a:0x3ffdc2f0 0x400d1038:0x3ffdc310
Rebooting…
ets Jun 8 2016 00:22:57
rst:0xc (SW_CPU_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
configsip: 0, SPIWP:0xee
clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
mode:DIO, clock div:2
load:0x3fff0018,len:4
load:0x3fff001c,len:3064
load:0x40078000,len:0
ho 12 tail 0 room 4
load:0x40078000,len:11504
entry 0x40078d64

I wonder what is going on?

Many thanks again for a fine system!


#2

Since I can’t find a way to delete this post, which is now no longer needed, I’ll reply that the system works now.

Sorry about the hassle.


#3

Thank you for reporting that you solved you issue :wink: