Can't register Nucleo F401RE board

Hi, Been away from Zerynth for a while, but now starting to look into it again.
I have a Nucleo F401RE board, and I’m pretty sure I had it registered and working about a year ago. However I have since changed computers, installed new OS (Linux Mint 19.2) and reinstalled Zerynth 2.3.2, and now I can’t access my board. When I try to register it I get an error 111 connection refused. There also seems to be an issue with libusb. I’ve tried installing pypy-libusb1, python-libusb1 and python3-libusb1 from Mint’s repository but the error persists. What do I have to do to register this board?
I’ve copied a copy of the log below.
Thanks, Ian

Loading settings...
Switched to auto mode
Ready!
Ok
Checking for updates...
[info] Starting temporary probe...
[info] Checking probe health...
[info] Starting OpenOCD...
GNU MCU Eclipse 64-bits Open On-Chip Debugger 0.10.0+dev-00487-gaf359c18 (2018-05-12-19:25)
Licensed under GNU GPL v2
For bug reports, read
 http://openocd.org/doc/doxygen/bugs.html
Info : auto-selecting first available session transport "hla_swd". To override use 'transport select '.
Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD
adapter speed: 2000 kHz
adapter_nsrst_delay: 100
none separate
Info : Listening on port 6666 for tcl connections
Info : Listening on port 4444 for telnet connections
Info : Unable to match requested speed 2000 kHz, using 1800 kHz
Info : Unable to match requested speed 2000 kHz, using 1800 kHz
Info : clock speed 1800 kHz
Error: libusb_open() failed with LIBUSB_ERROR_ACCESS
Error: open failed
in procedure 'init' 
in procedure 'ocd_bouncer'
[info] Checking probe health...
[info] Checking probe health...
[info] Checking probe health...
[info] Checking probe health...
[warning] Temporary probe may be dead...
[warning] [Errno 111] Connection refused
[warning] [Errno 111] Connection refused
[error] Can't retrieve chip id

Hi @mogplus8
As you said, I think these errors are related to the libusb particularly.
For instance, Are there any permissions that need to be modified/changed to make the libusb access the device? Is there any activation tool for that board?
I read some forum posts that some activation tools and activation commands are needed for the STM32, So this might be a similar problem :face_with_monocle:
Have you also updated the STlink firmware to latest version?

Hi Karim, thanks for your reponse.
I did a search for libusb and got thousands of hits. Most of them had the executable flag set, although most of them are owned by root. I don’t know which one Zerynth is trying to use.
Not sure what you mean by activation tool. I don’t remember needing to do that last time I tried it, but that doesn’t mean anything. I have enough trouble remembering what I had for breakfast yesterday.
I tried to program it with Arduino, but no luck there either. I’ve done a bit of searching, and it seems I may need to install STM32Cube software. There seem to be a few different flavours though, so still working my way through that.
I haven’t updated the STlink firmware, not entirely sure how to to do that. From my brief research so far maybe I have to use STM32Cube for that too. Not sure.
Harder than I thought…
:frowning:

Well, thought I’d solved at least part of the problem, by installing libusb-1.0-0-dev. That seemed to solve the libusb error. But I hadn’t installed STLink. When I tried that it wouldn’t install as it was not compatible with libusb-1.0-0-dev. I had to remove that first, and install a newer version of the library to satisfy the requirement of STLink. When I did that, a) the libusb error returned, and b) I still couldn’t register my board.
Officially giving up for now. Maybe I’ll try again in a few months.

Well, just for fun, I tried it again today, and it worked! I swear I never touched nuffink guv, no idea what’s changed. I’ve installed and uninstalled a few packages in the last few days, so maybe a library was installed or upgraded along the way, and now it seems to work.
:slight_smile: