Cannot connect to Arduino Zero


Running Version 54.0.2840.99 (2840.99)
Device menu stays gray, Target: nothing selected 
How do I proceed, thanks


I also try to connect a nodeMCU : it doesn’t show up in the Device manager toolbar. (same message Nothing selected)


Hi Jean-Luc,

Which platform are you using?
You can open the terminal and tap the command “ztc device discover” with the devices plugged into your pc and post me the results? (if you have a linux platform you have to navigate into the folder  “~/.zerynth2/dist/r2.0.5/ztc” before executing the command)

Let me know


Here is what “ztc device discover” gave me : (I am on a MacOs Sierra)
[warning]> Exception while discovering devices: 'vid’
Thx for your help


I was able to register/create vm/virtualize, and then flash code into both a NodeMCU and a Particle Core with version 2.04. But after installing version 2.05, I get the same behavior (nothing shows in the Target dropdown menu).

ztc device discover gives me the same exception error:
[warning]> Exception while discovering devices: 'vid’

I am running MacOS Sierra v10.12.3

I also tried a windows 10 PC, but didn’t have Zerynth version 2.04. I installed version 2.05 and it did show the NodeMCU device in the dropdown list. But when I tried to register it it failed at line 304  in saying ‘time’ is not defined. I added an ‘import time’ at the top of and was able to register/create vm/virtualize it.


I upgraded to 2.06
now I can connect to the Arduino Zero but when I try to virtualize I receive the following message:

[info] Starting device registration
[info] Burning bootloader…
[info] /Users/jldela/.zerynth2/tmp/tmpb6e13fnx/tmp.bin
[info] -ebpv: /Users/***/.zerynth2/sys/bossac/edgb: No such file or directory
[error] Can’t burn bootloader! --> -ebpv: /Users/***/.zerynth2/sys/bossac/edgb: No such file or directory


Hi Jean-Luc,

This issue will be fixed in our next release; in the meantime you can replace the file inside the zip attachment in this path:

This should fix and solve the problem. Let me know if everything works :slight_smile:


Its working !