Arduino Due V2.1 upload error


#1

Hi. Upgraded to V2.1, had some issues virtualizing my Due but got there in the end. Uploaded a program and it all worked. Well, sort of. Made a couple of changes to the program and tried to upload again. Now it says “no answer to probe”. What have I done wrong?
Thanks, Ian


#2


whoops. posted in error.


#3

Well, this one seems to have cured itself too. Seems the best way to solve problems is by posting a question on the board! Then the gremlins fix the problem for you.
:wink:


#4

:D 
The gremlins were very busy for the launch of the last release :# 


#5

Think I’ve found the problem. It doesn’t like doing an upload while the console is active. If I close the console then upload, all seems to be okay.
:wink: Ian


#6

Hi mogplus8,

yes to perform a new uplink, you have to close the serial monitor; this is because of the uplink procedure exchange bytecode through the serial port.


#7

Thanks Matteo. I finally figured it out when I was looking at the compile and upload log, and there were some lines in it that were output from print commands in the program that I’d last uploaded. It took a while but the penny finally dropped…
:wink: Ian


#8

Hi,
In version 2.0.11 when I upload my script, I have no problems, however in version 2.1, the following warning and error appears:

[warning] There are 2 missing symbols! This VM does not support the requested features!
Traceback (most recent call last):
  File “C:\Users\xxx\zerynth2\dist\r2.1.0\ztc\ztc.py”, line 111, in 
    cli()
  File “C:\Users\xxx\zerynth2\sys\python\lib\site-packages\click\core.py”, line 716, in call
    return self.main(*args, **kwargs)
  File “C:\Users\xxx\zerynth2\sys\python\lib\site-packages\click\core.py”, line 696, in main
    rv = self.invoke(ctx)
  File “C:\Users\xxx\zerynth2\sys\python\lib\site-packages\click\core.py”, line 1060, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File “C:\Users\xxx\zerynth2\sys\python\lib\site-packages\click\core.py”, line 889, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File “C:\Users\xxx\zerynth2\sys\python\lib\site-packages\click\core.py”, line 534, in invoke
    return callback(*args, **kwargs)
  File “C:\Users\xxx\zerynth2\dist\r2.1.0\ztc\uplinker\uplinker.py”, line 199, in uplink
    _uplink_dev(dev,bytecode,loop)
  File “C:\Users\xxx\zerynth2\dist\r2.1.0\ztc\uplinker\uplinker.py”, line 254, in _uplink_dev
    thebin = relocator.relocate(symbols,_memstart,_romstart)
  File “C:\Users\xxx\zerynth2\dist\r2.1.0\ztc\uplinker\relocator.py”, line 111, in relocate
    new_text_pad   =  self.align_to(new_text_end,16)-new_text_end
  File “C:\Users\xxx\zerynth2\dist\r2.1.0\ztc\uplinker\relocator.py”, line 65, in align_to
    return x if x%n==0 else x+(n-(x%n))
TypeError: unsupported operand type(s) for %: ‘NoneType’ and ‘int’

#9

Hi Marco,

Zerynth ecosystem has been released in r2.1.0 version.
Here more detail and here some advice to update your version.

Hope this can help you :slight_smile:


#10

Hi @“Matteo Cipriani”,
But I’ve already updated to 2.1 version. the problem is when I try to upload it gives-me the error above.
Did I misunderstand something?
Thanks.


#11

Hi Marco,

this is because you are using an Arduino Due with an older virtual machine; you have to create a new r2.1.0 virtual machine for your device (don’t worry the number of your available licenses will not decrement) and virtualize it again.

let me know 


#12

Hi @Matteo
Thats it. Its working now.
Thanks.