Announcing Zerynth Studio 2.0: download now!


We are excited to announce that Zerynth Studio 2.0 has been launched!

The first step to access the Zerynth ecosystem is to download the latest Zerynth Studio Release according to your platform from the Zerynth Download page, and choose between two options to complete the installation: online and offline.

WARNING for existing users: Moving from Zerynth r1.0.* to version r2.0.0 some precautions must be taken to avoid incurring in compatibility issues. More info in the section Migration Guide of the documentation.

What’s new in Zerynth 2.0

The 2.0 release involves innovations in all the aspects of the Zerynth Stack.

Zerynth Studio

  • Rebuilt from scratch (on top of NW.js browser and ACE editor) to be faster and more performant

  • Improved UI/UX:

    • Simplified Package Manager and “virtualization”

    • Batteries included. All the required libraries, packages and drivers are installed with the first installation.

    • New updates are shown through a notification icon in the bottom toolbar of the Zerynth Studio and can be all installed with a single click.

    • Multiple consoles with different windows

    • Quick fuzzy search bar

  • Main editor features:

    • Syntax highlighting

    • Syntax autocompletion

    • Automatic indent and outdent

    • Search and replace with regular expressions

    • Highlight matching parentheses

    • Displays hidden characters

    • Drag and drop text using the mouse

    • Line wrapping

    • Auto PEP8 funcionality

    • Useful shortcuts

    • Over 20 themes

    • Font size settings

  • Private Git repositories hosted on the Zerynth Backend

  • Simplified publishing of community libraries


An important new Zerynth element has been introduced, the Zerynth Toolchain (ZTC).

The ZTC allows managing all the aspects of the typical Zerynth workflow. It can be used with a command line interface, like the common Linux, Windows or Mac terminals, or it can be integrated with a custom IDE.

You can find more info in the dedicated section of the documentation.


  • The Zerynth 2.0 documentation is accessible at

  • Improved readability. We’ve added an index on the left of the page, so you can now walk through the documentation jumping from section to section without returning to the main page.

  • Improved content search. You can now search terms inside all the doc, and not only within the specific section you’re reading.

New supported boards

  • Redbear Nano BLE 2 and Blend BLE 2, as announced during the RedBear Kickstarter campaign.

  • Arduino/Genuino Zero. It’s now possible to program in Python for Arduino Zero, the most voted board in our latest survey.

You can find all the other boards yet supported in the table on this page.

Zerynth Connector

The Zerynth Connector is the next Zerynth big thing: a device manager that will be compatible with many cloud providers (like Azure, Kinetis, Bluemix, Amazon), exposing a simple API based interface for data gathering, actuation and mobile integration.

Zerynth App

We are also working to make the Zerynth App the definitive tool for prototyping UI for connected devices. The update will be released directly with the official release of Zerynth 2.0.0.

Ready to go PRO? Pre-order now!

Zerynth 2.0 is designed to enable production and deployment of IoT solutions thanks to Zerynth Studio PRO, that will include features like

  • Power Saving

  • Selectable RTOS

  • Over the Air update development

  • Hardware-driven Secured Firmware burned on the device at industrial volumes

  • …and many more

Zerynth Studio PRO will be provided at yearly subscription basis (you can find the pricing table here) you can pre-order today.

Not interested in going PRO? No problem! With the free version of Zerynth Studio, you will be able to use all the features you need to prototype your IoT solutions and to program for free up to 5 units of each supported board.

Happy coding!


Great work!
Could you confirm what happened to debugging & bytecode explorer in release v2.0?
Was missing in the beta and is missing in the RTM release. Appears the ztc CLI lacks any debugging bytecode lookup features too.

Do you plan on implementing it anytime soon? I believe this to be a critical feature for any serious or commercial development projects.

E.g. in <dist\r2.0.3\studio\zjs\app.js:125> the menu has no binding action and there are no respective UI debug methods.

Seriously considering going Pro but without this functionality will be holding off…


Hello to all the Community,

I just downloaded and installed the new version 2.0, and unfortunately the problems related to the Proxy with the beta version still exist.

Because of this limitation will be forced to not use ZERYNTH for my prototype.

Sin :frowning:



Hello @wezhunter and thanks for the feedback!

The bytecode explorer has been removed temporarily and it is undergoing some re-engineering. I would like to add the possibility to actually set breakpoints in Python and inspect the status of the VM. This would turn a simple explorer into a real debugger.

As for the exception explorer, the old UI is gone, however the exception messages in the console are still working. I am planning to add it back as a feature of the Quick Search Bar (something like CTRL+P  @… to jump to the code corresponding to exception coordinates).

Obviously all the new features will be made available first as ztc commands and then integrated in the Studio.


It would appear the feature to re-install the original particle firmware to my Photon is not available in the new v2.04.
Having just, once again, failed to get the WiFi Scan example to work on the Photon I would like to restore my Photon to its original state.
Any ideas how I can do this, please?


Thanks for the prompt and detailed update @Giacomo - really appreciated.
Looking forward to the initial debugging exception viewer (CTRL+P) concept you mentioned as currently have to use v1.0 studio to lookup coords of any raised runtime exceptions.

Of course I’d be more than willing to beta test and provide relevant detailed feedback in future, just let me know.




this morning I tried to install ZERYNTH 2.0 in OFFLINE mode but (as screenshoot attached)  prompted me to select a package repository …

Where can I download this package?

Thanls a lot



Hi @lucio1960,

you can download the offline packages from the Zerynth Studio download page, clicking on the links in the box “Offline Repos”.

Let me know

Best Regards


Hello Luigi, thanks for the indication, I downloaded and then unzipped. I tried to run the installation, but unfortunately the installation stops due to the company’s proxy. I hoped that this realease solve the problem but unfortunately it is not.


In case anybody runs into this error like I did (unable to find package file, with both offline and online), it was from installing on an external drive (storage space to be exact). I’m not sure if it was because my appdata was on another drive, but after an uninstall, I created a Zerynth2 symbolic link in my C drive pointing to the external drive and reinstalled (“link shell extension” is what I used). It’s a hackish way to do software installation, I admit, but in many cases I’ve seen software not work if it’s not on the C drive, work with a symlink or junction. 

For all I know Zerynth should have no problem running on a drive other than C:, but if you’re an SSD user like me chances are you made some system modifications like I did. 


Hello Ray, do you believe that my problem with the proxy could be solved with your suggestion ? Thanks a lot


Hi @lucio1960 
With the new Zerynth 2.0 it is possible to install all the packages by using an off-line repo that can be downloaded from here as explained by @Luigi 

This fixes only part of your problem because for the use of Zerynth it is mandatory to have access to our back-end servers where the VMs are generated.
In order to do this, you have to provide Zerynth Studio with an internet access that pass through your company proxy. In this post @Giacomo suggested you a possible procedure to enable proxy in Zerynth 2.0 but you have to replace the addresses available in the example with the IP addresses of your company proxy. 

If you want to share with us data that contains sensible information or network configurations feel free to drop as an email at

Please let us know if this works. 



today I submitted an official request to my IT to gain access to your server via Proxy and thus conclude the ZERYNTH 2.0 installation.

I’ll keep you up-to-date




finally with the help of IT I am able to complete the installation of ZERYNTH r2.0.4. Attached the screen shoots of the home page. Unfortunately, I believe that there are still problems. Checking for updates … message remains fixed and also connecting an STM32 or NODEMCU can not virtualization. Any idea about it? Still a proxy problem?





Hello ZERYNTH Community, I finally managed to install ZERYNTH 2.0.4 on my office PC. Unfortunately it is not yet possible to virtualize boards STM32 or NODEMCU (Can’t burn bootloader!). I enclose two screenshoot of the problem.Ideas about it?


Hello community,

I want to refer a case to see if you can solve my problem of corporate Proxy.

If I perform virtualization on the home PC, I can write code and upload it to the board on the office PC?

Thanks a lot



Can someone help me  :’(

Thanks a lot



Hi Lucio,
You can use your virtualized board without problems.
The only thing is that: for the first utilization in the “office” installation you need to register again the board (don’t worry, the number of your free virtual machine doesn’t increse).

Keep me posted  :slight_smile:


Hello Matteo,

could you please indicate the registration process of the board in detail.

This information will be helpful to my IT manager to understand how to manage the Proxy.

Thank a lot