1 ESP32 Register Device Error Mac


#1

Continuing the discussion from ESP32 Register Device Error Mac:

Hello, I am getting the same error:
[info] Burning bootloader…
[error] Can’t burn bootloader! -->Can’t convert ‘NoneType’ object to str implicitly

I went to the recommended link provided by Matteo Cipriani in this thread which takes you to a driver page on the Silabs site for CP210x USB to UART Bridge VCP Drivers

However, installing this driver does not seem to help. I’m new to Zernyth and not sure on the best way to troubleshoot this issue. Any advice would be helpful - the ESP32 device I purchased is brand new and recognized by Zernyth - just cannot register it…

Thanks in advance, Keith


#2

I think you have to make sure that the drivers are installed correctly, to establish communication between the ESP32 based board and the laptop.

Have you installed the appropriate version of the driver for your OS?
For instance, which OS do you use? does the OS identify the device correctly?


#3

Hi @ktomes,

what @karimhamdy1 says is correct, just another question: what ESP32-based board are you using?


#4

I am using the ESP32DevKitC. It was a simple issue - my MAC security settings were not allowing VCP driver for USB to UART to be applied. Once I changed that in settings everything worked. I also found this thread on github which was helpful and covers a few more possible resolutions if this issue is encountered.