frame

[FiX] Missing Pycom Fipy v1.0 in Zerynth Studio r2.0.11

edited January 19 in Installation & Login
Hi guys, as you probably already know, we've just released the version r2.0.11 of Zerynth, that provides the support for two Pycom boards: WiPy 3.0 and FiPy 1.0 (here more details)

If you have installed Zerynth from scratch you can skip the following advice, because all the necessary packages are correctly installed on your system.

But if you've upgraded from r2.0.10, probably you miss one device package (the Pycom Fipy v1.0).

To check this, you have to:
- open the "Virtual Device Table" by clicking the "Device Manager Toolbar" and select the "Choose virtual devices..." option.
- in the search field, tap Pycom
- ... and if the resulting table is composed of only one row ... you are unlucky :disappointed:

But don't worry, here's the solution :smiley:

To bring this new missing device in your Zerynth Studio instance you can install again the r2.0.11 version by clicking the "Reinstall" button before Zerynth Studio starting or waiting for our next patch that will be released in few weeks.

Stay tuned for new updates
Happy coding to everyone!!!
Matteo Cipriani
Zerynth Support Team

Comments

  • ta1dbta1db Member
    Hi Matteo,
    * Where is the "reinstall button"?
    * Can we remove the installation r2.0.10 using Preferences>Remove Installation menu item.
    * When I start the new version I get the following warning; what doest it mean?
    Thanks.
  • Hi ta1db,

    You can click in help-->about menu and confirm that you have upgraded to r2.0.11.

    Then the message you receive from Zerynth Studio console says that you have the old version of the installer; to solve this, you can click on the blue "guide" word of the message in the console or here (https://docs.zerynth.com/latest/official/core.zerynth.docs/migration3/docs/index.html) and view the step-by-step tutorial in our documentation.

    You have to download again from here (https://www.zerynth.com/zerynth-studio/) the Zerynth installer for your platform and install again the installer (click "yes I want to install over old installation" if similar message comes out).

    Once finished, you can restart Zerynth Studio and the "Reinstall" button will appear in the popup window.

    Let me know if this can help you :)
    Matteo Cipriani
    Zerynth Support Team
  • ta1dbta1db Member
    edited January 23
    Hi Matteo,
    I've already upgraded to r2.0.11 and help>about says r2.0.11-base
    Well, I think it's better for me to wait the next patch instead of a full reinstall.
    By the way could you please explain the following warning I get: 
  • Hi ta1db,

    Zerynth version r2.0.11 simplifies the package management system and allows to directly publish Zerynth community libraries on Github. However, in order to do so, Zerynth Studio needs to rely on a new version of the Zerynth installer (the small window that pops up before Zerynth Studio starts), which is now faster and more stable.

    Sadly, due to permission issues on different platforms, Zerynth Studio can’t automatically update the installer and therefore user intervention is needed. Follow this simple guide to migrate the installer.

    So to install future patches and releases the Zerynth Installer must be replaced and installed over the old one (here you can find our documentation with the new screenshots of the Zerynth Installer).

    Then if you don't want to re-install Zerynth Studio from scratch and wait for the next patch you can do it, but if you don't upgrade the installer version you cannot able to install future updates.

    Keep me posted ;)



    Matteo Cipriani
    Zerynth Support Team
  • ta1dbta1db Member
    edited January 24
    I did it very easily: following the simple guide here as you recommended. I got the new version of the Zerynth Installer having the "reinstall button" and reinstalled the new version using this button, now I see 2 pycoms, no more warning. Thank you.
Sign In or Register to comment.

ZERYNTH Community

@ 2016 Zerynth.com, all rights reserved.