frame

Sparkfun Thing32: Creating VM for sparkfun_esp32thing... [info] Creating vm for device zs:sparkfun_e

I've just downloaded Zerynth Studio (not professional) Version 54.0.2840.99 (2840.99) on OS X 10.12.6. 
Zerynth recognized the connected Thing32 and I was able to register it. However, when I try to virtualize it, I get the following error:
Creating VM for sparkfun_esp32thing...
[info] Creating vm for device zs:sparkfun_esp32thing:b1d09f79d831e19e45e707b0a881b3993b5893f0
[fatal] Error while creating vm: vm limit reached

I have never virtualized a device, and my profile for "your free VMs" shows 0/6 for all, including Sparkfun ESP32 Thing.

I've tried twice - same result. Registration worked without problems:

[info] Starting device registration
[info] Burning bootloader...
[info] esptool.py v2.0
[info] Connecting....
[info] Chip is ESP32D0WDQ6 (revision 0)
[info] Uploading stub...
[info] Running stub...
[info] Stub running...
[info] Configuring flash size...
[info] Auto-detected Flash size: 4MB
[info] Compressed 11408 bytes to 7503...
[info] 
[info] Writing at 0x00001000... (100 %)
[info] Wrote 11408 bytes (7503 compressed) at 0x00001000 in 0.7 seconds (effective 135.8 kbit/s)...
[info] Hash of data verified.
[info] Compressed 237840 bytes to 97665...
[info] 
[info] Writing at 0x00010000... (16 %)
[info] Writing at 0x00014000... (33 %)
[info] Writing at 0x00018000... (50 %)
[info] Writing at 0x0001c000... (66 %)
[info] Writing at 0x00020000... (83 %)
[info] Writing at 0x00024000... (100 %)
[info] Wrote 237840 bytes (97665 compressed) at 0x00010000 in 8.7 seconds (effective 219.4 kbit/s)...
[info] Hash of data verified.
[info] Compressed 3072 bytes to 156...
[info] 
[info] Writing at 0x00008000... (100 %)
[info] Wrote 3072 bytes (156 compressed) at 0x00008000 in 0.0 seconds (effective 765.9 kbit/s)...
[info] Hash of data verified.
[info] Compressed 1024 bytes to 20...
[info] 
[info] Writing at 0x00390000... (100 %)
[info] Wrote 1024 bytes (20 compressed) at 0x00390000 in 0.0 seconds (effective 509.8 kbit/s)...
[info] Hash of data verified.
[info] 
[info] Leaving...
[info] Hard resetting...
[info] Found chipid: 03ea4a50a90c
[info] Device Sparkfun ESP32 Thing registered with uid: a18lkUY5RQaEBR3deQqmAw
Registration successful! Now you can virtualize your sparkfun_esp32thing

Help appreciated!

Tagged:

Comments

  • Hi Bernhard Boser,

    thanks for joining our community; there was a minor issue in our backend that it is already solved and all is up and running.
    Now you should be able to virtualize your device; please let me know if all works well :)
    Matteo Cipriani
    Zerynth Support Team
Sign In or Register to comment.

ZERYNTH Community

@ 2016 Zerynth.com, all rights reserved.