frame

Particle Electron not showing port after virtualizing

Greeting. I am new to Zerynth but look forward to using the Pro version.

I am trying to use Particle Electron.
I can connect using DFU and Register and virtualize the device, but can't upload firmware to device after that.
On Info...it shows no port.

Before virtualizing the Electron shows up in Device Manager(Windows 10) as Serial Port.
In DFU mode shows up as Electron DFU MODE.
After VM is loaded no Serial Port in Device Manager...can not upload to VM.

Any Ideas?

Thanks

Comments

  • Hi pmjackson,

    thanks to join our community!!! 
    This is a known bug that we have already fixed (will be released very soon).

    The problem is related to CDC initialization in Standard Mode; when the Particle Electron is virtualized and returns in Standard Mode, serial port over USB is not recognized.

    Stay tuned, I warn you as soon as new virtual machine for Particle Electron is available :)

    Matteo Cipriani
    Zerynth Support Team
  • Thank you Matteo, 
    I am glad to know the situation and look forward to the VM update.
    Do you know when very soon will be?

    Regards

  • Hi pmjackson,

    very soon will be... now :) 
    New Virtual Machine for particle Electron with CDC initialization bug fixed is available.

    You can create a new virtual machine and load again in your Particle Electron (DFU Mode); at the end of virtualization, you should see in "Device Management Widget" the Particle Electron device in Standard Mode ready to be uplinked with your firmware.

    Let me know if everything works well

    Matteo Cipriani
    Zerynth Support Team
  • Hello Matteo,
    Very excited! It works.
    Thanks for the fast response.

    I look forward to buying many VM's.

    Pat Jackson
Sign In or Register to comment.

ZERYNTH Community

@ 2016 Zerynth.com, all rights reserved.